summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-18 09:06:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-18 09:36:07 +0200
commit27dc861550a706df120c87f91d3d0a93338d3f69 (patch)
tree594cdbf83134a4fdda53988ad9c02f7b5bc22d15 /app-portage
parentapp-portage/flaggie: Remove obsolete upstream maintaer (diff)
downloadgentoo-27dc861550a706df120c87f91d3d0a93338d3f69.tar.gz
gentoo-27dc861550a706df120c87f91d3d0a93338d3f69.tar.bz2
gentoo-27dc861550a706df120c87f91d3d0a93338d3f69.zip
app-portage/flaggie: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/flaggie/flaggie-0.2.1-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/flaggie/flaggie-0.2.1-r2.ebuild b/app-portage/flaggie/flaggie-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..5ced01008064
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.2.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="https://github.com/mgorny/flaggie/"
+SRC_URI="https://github.com/mgorny/flaggie/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn "Please note that flaggie creates backups of your package.* files"
+ ewarn "before performing each change through appending a single '~'."
+ ewarn "If you'd like to keep your own backup of them, please use another"
+ ewarn "naming scheme (or even better some VCS)."
+ if ! has_version app-shells/gentoo-bashcomp; then
+ elog
+ elog "If you want to use bash-completion, you need to install:"
+ elog " app-shells/gentoo-bashcomp"
+ fi
+}