summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-11 20:08:53 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-08-11 20:08:53 -0400
commit92358b3c41b2aad87d7df18e27cb85808a5870ac (patch)
tree74fbf6a31cc54e6f1ddb3607dd49b10ddd33e29d /app-portage
parentcosmetic: set up new $Id$ header in lieu of former CVS $Header$ header. These... (diff)
downloadgentoo-92358b3c41b2aad87d7df18e27cb85808a5870ac.tar.gz
gentoo-92358b3c41b2aad87d7df18e27cb85808a5870ac.tar.bz2
gentoo-92358b3c41b2aad87d7df18e27cb85808a5870ac.zip
app-portage/grs: first 0.1 release.
Package-Manager: portage-2.2.20
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/grs/Manifest1
-rw-r--r--app-portage/grs/grs-0.1.ebuild43
-rw-r--r--app-portage/grs/grs-9999.ebuild7
3 files changed, 49 insertions, 2 deletions
diff --git a/app-portage/grs/Manifest b/app-portage/grs/Manifest
new file mode 100644
index 000000000000..0fd826caa1d1
--- /dev/null
+++ b/app-portage/grs/Manifest
@@ -0,0 +1 @@
+DIST grs-0.1.tar.gz 32017 SHA256 38018649a6c767e3e295a24bec6fd880c63f892dd74a0f34ebc0bdc22c2683a8 SHA512 89f005c520f7ee0db4c57764592fe6555d75e1c78dd3dc0c224bd2197bebfad34a1b1279fbef75411949bfcd430dc3ebf57e929934a193bbc0da9d56a2944f75 WHIRLPOOL 31d612470ecc3b13388ddee1ebac7fb8584f5642491b09cda3ed3575ff303c70da25460b56a9d9595966a681ee21ec0b93f2d0fee91874dd18c7494e74cb384e
diff --git a/app-portage/grs/grs-0.1.ebuild b/app-portage/grs/grs-0.1.ebuild
new file mode 100644
index 000000000000..2b937e997f6c
--- /dev/null
+++ b/app-portage/grs/grs-0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/grss.git"
+ inherit git-2
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Suite to build Gentoo Reference Systems"
+HOMEPAGE="http://dev.gentoo.org/~blueness/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-arch/tar[xattr]
+ app-crypt/md5deep
+ dev-libs/libcgroup
+ dev-vcs/git
+ net-misc/rsync
+ sys-apps/portage
+ || (
+ sys-kernel/genkernel
+ sys-kernel/genkernel-next
+ )"
+
+src_install() {
+ distutils-r1_src_install
+ echo "CONFIG_PROTECT=\"/etc/grs/systems.conf\"" > "${T}"/20grs
+ doenvd "${T}"/20grs
+}
diff --git a/app-portage/grs/grs-9999.ebuild b/app-portage/grs/grs-9999.ebuild
index 8b9f64a6d7ff..2b937e997f6c 100644
--- a/app-portage/grs/grs-9999.ebuild
+++ b/app-portage/grs/grs-9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://anongit.gentoo.org/proj/grss.git"
inherit git-2
else
- SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
+ SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -31,7 +31,10 @@ RDEPEND="
dev-vcs/git
net-misc/rsync
sys-apps/portage
- sys-kernel/genkernel"
+ || (
+ sys-kernel/genkernel
+ sys-kernel/genkernel-next
+ )"
src_install() {
distutils-r1_src_install