summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-22 18:40:23 +0100
committerSam James <sam@gentoo.org>2022-04-22 18:43:06 +0100
commitebabb03c2f7b829821948fcc28113a1e3fec6a08 (patch)
tree2a48b2efdb43f18c59a68e67e047d951c69ff044 /app-portage
parentmail-mta/courier: fix ROOT check in pkg_postinst (diff)
downloadgentoo-ebabb03c2f7b829821948fcc28113a1e3fec6a08.tar.gz
gentoo-ebabb03c2f7b829821948fcc28113a1e3fec6a08.tar.bz2
gentoo-ebabb03c2f7b829821948fcc28113a1e3fec6a08.zip
app-portage/cfg-update: fix ROOT check in pkg_postinst
With EAPI 7+, ROOT and others will be blank (not /). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.9-r2.ebuild (renamed from app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild)6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild b/app-portage/cfg-update/cfg-update-1.8.9-r2.ebuild
index a84b7363f54a..beacc660fe49 100644
--- a/app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild
+++ b/app-portage/cfg-update/cfg-update-1.8.9-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,7 @@ RDEPEND="
S="${WORKDIR}/rich0-cfg-update-2f10786"
pkg_prerm() {
- if [[ ${ROOT} == / ]]
+ if [[ -z ${ROOT} ]]
then
ebegin "Disabling portage hook"
cfg-update --ebuild --disable-portage-hook
@@ -80,7 +80,7 @@ pkg_postinst() {
echo
fi
- if [[ ${ROOT} == / ]]
+ if [[ -z ${ROOT} ]]
then
ebegin "Moving backups to /var/lib/cfg-update/backups"
/usr/bin/cfg-update --ebuild --move-backups