summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-15 19:04:06 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-15 19:04:06 +0200
commit215dffe54f27a95219ac3132b7aa973874ccef06 (patch)
treea0ebd4ac81e11ced317d4383f86f9916ed64017f /app-shells
parentkde-apps/kopete: Drop 16.12.3 (r0) (diff)
downloadgentoo-215dffe54f27a95219ac3132b7aa973874ccef06.tar.gz
gentoo-215dffe54f27a95219ac3132b7aa973874ccef06.tar.bz2
gentoo-215dffe54f27a95219ac3132b7aa973874ccef06.zip
app-shells/thefuck: Version bump to 3.16
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/thefuck-3.16.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
index 136dcaa80b10..b8fb485b2333 100644
--- a/app-shells/thefuck/Manifest
+++ b/app-shells/thefuck/Manifest
@@ -1,2 +1,3 @@
DIST thefuck-3.14.tar.gz 801989 SHA256 5757d7ba05ead08e867ab6b41e34d6f27fe38d5bb8af1ffc097aeed5ccc9c72f SHA512 b6963e4ab6de7c98bf324498f8f4ac2049a038bf50a856dcfe14570fa6351c9eba3ce9b9f30745ae37578750f8978003875682ffecefdc29e7baeee36d2fba3a WHIRLPOOL 795ba476b615d7b1de02c7e86679782af68fb698c31aae6115d380c330a5e0c43c5226a3a5af48ba9d3371ac14726ce1450437a8969bc109bf72f84e18f7f9d8
DIST thefuck-3.15.tar.gz 810304 SHA256 30d0c1e2c2540396c9719316f2f0d14fa1820ee8c71d6f160bc4d50283d0aaef SHA512 6b7ba1fcf94e08c572d7ec0c3e03517d1596088fb5e00f4300c75e038aa87d8f57cbfbb2a37aea7932498d513c33353a568a3e83e168d73ebee51f9c283b4889 WHIRLPOOL 17bd375c75d8a772b843370a0e04da4f321ce87b815b81c6a742376c2084f22be04a7f399be5bab494e7064ddf063680af8686830fda0ede7e8f3887e524329e
+DIST thefuck-3.16.tar.gz 812419 SHA256 536582810a522144c8bc1ce69b3882979841af1b7aa61e9b245d2b216b77304b SHA512 f6c383fddcc40d11914b095eb9e00e856c5374ffbbb495f6f07a532e5f6458f8051a2881c80e85c743a7a876c6a70aaa78140aa09cbb1b78460a959752d88aca WHIRLPOOL 5a9895c011f943b92be1bd63bc0ea6fa486a8f2eed08394f7e06c1e28dd849a8222e34ced5342e4a60cf5c8e7acbfa61f8bc618abfebf42513b37f9ec36b72b1
diff --git a/app-shells/thefuck/thefuck-3.16.ebuild b/app-shells/thefuck/thefuck-3.16.ebuild
new file mode 100644
index 000000000000..e7a29582bd74
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test || die
+}