summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-04 13:00:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-04 13:00:26 +0100
commit8a013bba39fe6c55500499ed293e1f01341af386 (patch)
treea9524474785b2ab83b95f8c491819e49d1121831 /app-shells
parentsys-firmware/intel-microcode: drop old (diff)
downloadgentoo-8a013bba39fe6c55500499ed293e1f01341af386.tar.gz
gentoo-8a013bba39fe6c55500499ed293e1f01341af386.tar.bz2
gentoo-8a013bba39fe6c55500499ed293e1f01341af386.zip
app-shells/zsh: Bump to version 5.7.1
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/Manifest2
-rw-r--r--app-shells/zsh/zsh-5.7.1.ebuild216
2 files changed, 218 insertions, 0 deletions
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
index 382379183ed9..b65727d06f44 100644
--- a/app-shells/zsh/Manifest
+++ b/app-shells/zsh/Manifest
@@ -1,4 +1,6 @@
DIST zsh-5.6.2-doc.tar.xz 3198932 BLAKE2B 7e701bb12e0114b7d9847caad1146fa3d538f8f6d859a765037660fb18341f1c79002811a42ec795e41eb2bbe899e12d4bcd055ea5c66e7b73bd488bdf8bbb55 SHA512 5102314e2857b032c6e6b4b715c261970b2f0c28663aff99fb87f7bb6c3971f88f8e8892ed349793570beae3fb68ff7923c82e99a3c1bb485e4639f01caaad4a
DIST zsh-5.6.2.tar.xz 3077368 BLAKE2B 8c6ce22436f9f51eff809c779efad02f4a0730b4431630ab305abc9f1ef722698f7c565d0aa421b0d94c21f2c830f9d529709fd62a4205be1a20acf0f94a845a SHA512 f0a49e41b55eb478692ab5471d7c9828956b7e96bc82944202b0ef1c49a889b21a0e7682aa5f59fd0054ebfd866c2244c8a622e7aa46c13038af5c226c48a3a2
DIST zsh-5.7-doc.tar.xz 3062428 BLAKE2B 1ee818fd3625c3c96add6fb8f0ccb42dd05eeb33b4f4513e4e436974f835465fdb9dd4092c652bcda24762bc39307946e14c4969e03038ae43f77c24871a5449 SHA512 4b5f256ed39c0594daf2fdb2f995c60944c70556438b986fcf6f4e40dbfdc58e70eb65691c841d5dbb973a20b30255abe55ed140482b7afd446e1911c4efd395
+DIST zsh-5.7.1-doc.tar.xz 3062112 BLAKE2B cb67aada97d79b4b5b1116fb0737294785a2a510c2f4396cf77b671b62631e778ee9d57a32dcd257e079a9e4c35acaeeb68c0ec951b6ae8d8d8b647c05ef365c SHA512 e51bc8eb408bcb20bf8a4f0b8588f7803fdd433445efa282f598a3bec4575cba7feaad117cd2d5077f51150bf0ba41a673ffb925ade33c435db498f1d791cc8c
+DIST zsh-5.7.1.tar.xz 3126308 BLAKE2B 4f1aa2d5aea0341ba7839cf05687020889b5ca6879654a376ce838986211af4bddb7ab521a8a35cc06701f730a75a9778c633726b447f31845f5c140ec1e8d80 SHA512 a6aa88e1955a80229a4784a128866e325f79a8b5f73c922ab480048411036f1835cbb31daa30ab38bd16ab2a50040eda8f4f1f64704b21b6acc3051b1dbf18d0
DIST zsh-5.7.tar.xz 3124708 BLAKE2B 6b3822d3bb647aaf1072b9d499dbe9a65dc6cec0b83fb7fb09050e26bcc71fc0fb2846a1b754f9f206b602632add39e52465c1092f131f9000a149dbd2b469de SHA512 cfef5604d6ff30aeb081ed2a2660c861027c0a90169231cdb6b19093ffa6d63946be7b1fde527769e60e5b14bb6853b590bf4a207b63d6ec66fffd30d9a94958
diff --git a/app-shells/zsh/zsh-5.7.1.ebuild b/app-shells/zsh/zsh-5.7.1.ebuild
new file mode 100644
index 000000000000..7455f1937729
--- /dev/null
+++ b/app-shells/zsh/zsh-5.7.1.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic prefix
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://git.code.sf.net/p/zsh/code"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SRC_URI="https://www.zsh.org/pub/${P}.tar.xz
+ https://www.zsh.org/pub/old/${P}.tar.xz
+ mirror://sourceforge/${PN}/${P}.tar.xz
+ doc? (
+ https://www.zsh.org/pub/${P}-doc.tar.xz
+ mirror://sourceforge/${PN}/${P}-doc.tar.xz
+ )"
+fi
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="https://www.zsh.org/"
+
+LICENSE="ZSH gdbm? ( GPL-2 )"
+SLOT="0"
+IUSE="caps debug doc examples gdbm maildir pcre static unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0=
+ static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
+ caps? ( sys-libs/libcap )
+ pcre? (
+ >=dev-libs/libpcre-3.9
+ static? ( >=dev-libs/libpcre-3.9[static-libs] )
+ )
+ gdbm? ( sys-libs/gdbm:= )
+ !<sys-apps/baselayout-2.4.1
+"
+DEPEND="sys-apps/groff
+ ${RDEPEND}"
+PDEPEND="
+ examples? ( app-doc/zsh-lovers )
+"
+if [[ ${PV} == 9999* ]] ; then
+ DEPEND+=" app-text/yodl
+ doc? (
+ sys-apps/texinfo
+ app-text/texi2html
+ virtual/latex-base
+ )"
+fi
+
+src_prepare() {
+ if [[ ${PV} != 9999* ]]; then
+ # fix zshall problem with soelim
+ ln -s Doc man1 || die
+ mv Doc/zshall.1 Doc/zshall.1.soelim || die
+ soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
+
+ # add openrc specific options for init.d completion
+ eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
+ fi
+
+ default
+
+ if [[ ${PV} == 9999* ]] ; then
+ sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --enable-etcdir="${EPREFIX}"/etc/zsh
+ --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help
+ --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions
+ --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions
+ --enable-function-subdirs
+ --with-tcsetpgrp
+ $(use_enable maildir maildir-support)
+ $(use_enable pcre)
+ $(use_enable caps cap)
+ $(use_enable unicode multibyte)
+ $(use_enable gdbm)
+ )
+
+ if use static ; then
+ myconf+=( --disable-dynamic )
+ append-ldflags -static
+ fi
+ if use debug ; then
+ myconf+=(
+ --enable-zsh-debug
+ --enable-zsh-mem-debug
+ --enable-zsh-mem-warning
+ --enable-zsh-secure-free
+ --enable-zsh-hash-debug
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf+=( --enable-libs=-liconv )
+ append-ldflags -Wl,-x
+ fi
+
+ econf "${myconf[@]}"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ # removed cap and curses because linking failes
+ sed -e "s,link=no,link=static,g" \
+ -e "/^name=zsh\/cap/s,link=static,link=no," \
+ -e "/^name=zsh\/curses/s,link=static,link=no," \
+ -i "${S}"/config.modules || die
+ if ! use gdbm ; then
+ sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
+ "${S}"/config.modules || die
+ fi
+ fi
+}
+
+src_compile() {
+ default
+
+ if [[ ${PV} == 9999* ]] && use doc ; then
+ emake -C Doc everything
+ fi
+}
+
+src_test() {
+ addpredict /dev/ptmx
+ local i
+ for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
+ rm "${S}"/Test/${i} || die
+ done
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install $(usex doc "install.info" "")
+
+ insinto /etc/zsh
+ export PREFIX_QUOTE_CHAR='"' PREFIX_EXTRA_REGEX="/EUID/s,0,${EUID},"
+ newins "$(prefixify_ro "${FILESDIR}"/zprofile-4)" zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+ newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
+
+ local i
+
+ # install miscellaneous scripts (bug #54520)
+ sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
+ -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
+ -i {Util,Misc}/* || die
+ for i in Util Misc ; do
+ insinto /usr/share/zsh/${PV%_*}/${i}
+ doins ${i}/*
+ done
+
+ # install header files (bug #538684)
+ insinto /usr/include/zsh
+ doins config.h Src/*.epro
+ for i in Src/{zsh.mdh,*.h} ; do
+ sed -e 's@\.\./config\.h@config.h@' \
+ -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
+ -i "${i}"
+ doins "${i}"
+ done
+
+ dodoc ChangeLog* META-FAQ NEWS README config.modules
+
+ if use doc ; then
+ pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
+ docinto html
+ dodoc Doc/*.html
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
+ popd >/dev/null
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you want to enable Portage completions and Gentoo prompt,"
+ elog "emerge app-shells/gentoo-zsh-completions and add"
+ elog " autoload -U compinit promptinit"
+ elog " compinit"
+ elog " promptinit; prompt gentoo"
+ elog "to your ~/.zshrc"
+ echo
+ elog "Also, if you want to enable cache for the completions, add"
+ elog " zstyle ':completion::complete:*' use-cache 1"
+ elog "to your ~/.zshrc"
+ echo
+ elog "Note that a system zprofile startup file is installed. This will override"
+ elog "PATH and possibly other variables that a user may set in ~/.zshenv."
+ elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
+ elog "or other user startup files that are sourced after the system zprofile."
+ echo
+ elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
+ elog "one method is to use a separate path-setting file that is conditionally sourced"
+ elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
+ elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
+ echo
+ elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
+ echo
+ fi
+}