summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-26 04:40:36 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-26 04:41:07 +0200
commitbb79c6838cd01fc60a7c9198130d709c500d442a (patch)
treeacb8bc2a82dde4ec5f0b34e88e0662cded29879a /app-shells
parentprofiles/arch/powerpc/package.use.mask: mask glibc[static-pie] (diff)
downloadgentoo-bb79c6838cd01fc60a7c9198130d709c500d442a.tar.gz
gentoo-bb79c6838cd01fc60a7c9198130d709c500d442a.tar.bz2
gentoo-bb79c6838cd01fc60a7c9198130d709c500d442a.zip
app-shells/bash: Minor QA fixes
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-4.4_p23-r1.ebuild5
-rw-r--r--app-shells/bash/bash-5.0_p11.ebuild5
-rw-r--r--app-shells/bash/bash-5.0_p16.ebuild5
-rw-r--r--app-shells/bash/bash-5.0_p17.ebuild5
4 files changed, 8 insertions, 12 deletions
diff --git a/app-shells/bash/bash-4.4_p23-r1.ebuild b/app-shells/bash/bash-4.4_p23-r1.ebuild
index dc2d39a7d27f..d40bcd6d09b1 100644
--- a/app-shells/bash/bash-4.4_p23-r1.ebuild
+++ b/app-shells/bash/bash-4.4_p23-r1.ebuild
@@ -56,7 +56,6 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- !<sys-apps/portage-2.1.6.7_p1
"
# we only need yacc when the .y files get patched (bash42-005)
#DEPEND+=" virtual/yacc"
@@ -218,12 +217,12 @@ src_install() {
if use examples ; then
for d in examples/{functions,misc,scripts,startup-files} ; do
exeinto /usr/share/doc/${PF}/${d}
- insinto /usr/share/doc/${PF}/${d}
+ docinto /usr/share/doc/${PF}/${d}
for f in ${d}/* ; do
if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
doexe ${f}
else
- doins ${f}
+ dodoc ${f}
fi
done
done
diff --git a/app-shells/bash/bash-5.0_p11.ebuild b/app-shells/bash/bash-5.0_p11.ebuild
index 1cb910d9157b..cf6f13f0d787 100644
--- a/app-shells/bash/bash-5.0_p11.ebuild
+++ b/app-shells/bash/bash-5.0_p11.ebuild
@@ -56,7 +56,6 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- !<sys-apps/portage-2.1.6.7_p1
"
# we only need yacc when the .y files get patched (bash42-005)
#DEPEND+=" virtual/yacc"
@@ -222,12 +221,12 @@ src_install() {
if use examples ; then
for d in examples/{functions,misc,scripts,startup-files} ; do
exeinto /usr/share/doc/${PF}/${d}
- insinto /usr/share/doc/${PF}/${d}
+ docinto /usr/share/doc/${PF}/${d}
for f in ${d}/* ; do
if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
doexe ${f}
else
- doins ${f}
+ dodoc ${f}
fi
done
done
diff --git a/app-shells/bash/bash-5.0_p16.ebuild b/app-shells/bash/bash-5.0_p16.ebuild
index 1cb910d9157b..cf6f13f0d787 100644
--- a/app-shells/bash/bash-5.0_p16.ebuild
+++ b/app-shells/bash/bash-5.0_p16.ebuild
@@ -56,7 +56,6 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- !<sys-apps/portage-2.1.6.7_p1
"
# we only need yacc when the .y files get patched (bash42-005)
#DEPEND+=" virtual/yacc"
@@ -222,12 +221,12 @@ src_install() {
if use examples ; then
for d in examples/{functions,misc,scripts,startup-files} ; do
exeinto /usr/share/doc/${PF}/${d}
- insinto /usr/share/doc/${PF}/${d}
+ docinto /usr/share/doc/${PF}/${d}
for f in ${d}/* ; do
if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
doexe ${f}
else
- doins ${f}
+ dodoc ${f}
fi
done
done
diff --git a/app-shells/bash/bash-5.0_p17.ebuild b/app-shells/bash/bash-5.0_p17.ebuild
index 1cb910d9157b..cf6f13f0d787 100644
--- a/app-shells/bash/bash-5.0_p17.ebuild
+++ b/app-shells/bash/bash-5.0_p17.ebuild
@@ -56,7 +56,6 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- !<sys-apps/portage-2.1.6.7_p1
"
# we only need yacc when the .y files get patched (bash42-005)
#DEPEND+=" virtual/yacc"
@@ -222,12 +221,12 @@ src_install() {
if use examples ; then
for d in examples/{functions,misc,scripts,startup-files} ; do
exeinto /usr/share/doc/${PF}/${d}
- insinto /usr/share/doc/${PF}/${d}
+ docinto /usr/share/doc/${PF}/${d}
for f in ${d}/* ; do
if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
doexe ${f}
else
- doins ${f}
+ dodoc ${f}
fi
done
done