summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/gtranslator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/gtranslator')
-rw-r--r--app-text/gtranslator/Manifest2
-rw-r--r--app-text/gtranslator/gtranslator-2.91.6.ebuild72
-rw-r--r--app-text/gtranslator/gtranslator-2.91.7.ebuild76
-rw-r--r--app-text/gtranslator/metadata.xml5
4 files changed, 155 insertions, 0 deletions
diff --git a/app-text/gtranslator/Manifest b/app-text/gtranslator/Manifest
new file mode 100644
index 000000000000..d84212607680
--- /dev/null
+++ b/app-text/gtranslator/Manifest
@@ -0,0 +1,2 @@
+DIST gtranslator-2.91.6.tar.xz 2235796 SHA256 a1fd4b17b1f32cc7223a31d34e34f95b20acc7b5a23768351a34ff0b7a4bcdf6 SHA512 5cb5ca318201a08b530390073a9e87be93c6fb30629e899d6d23e38a790771cacf5188a26c61584a24170a3a12e9d1670440fd3f4eb3eab2da1a76a7ec4c385f WHIRLPOOL 6241316e3b759f4d21934ca9fce06cb2e3019288d3916957b5316112eab66fea3674c4b83974afdbdc19c905da86cd65939f83e9862414b2383b8a4f397d1659
+DIST gtranslator-2.91.7.tar.xz 2835836 SHA256 2b25b45b33e4aa856953b4a5da1d98bd51a343ddb479aeae3934bfe0c3651f9d SHA512 8d2a582e06ab0fecb9c18bde372ca0cd02d426155d4b30b876bd8f2e177c88c79d410adb0297ab85f18a952eeef32c17352cde18eda3c4c4fe33833db25022b5 WHIRLPOOL f39557d03cd0d8d833478b8e9d356c4db6ac13a9a5ebd2c09c0bc022a383342d490762eb53b99a1f32182c348e27ab21aa5d2ef1950f19b0913584997e1cac98
diff --git a/app-text/gtranslator/gtranslator-2.91.6.ebuild b/app-text/gtranslator/gtranslator-2.91.6.ebuild
new file mode 100644
index 000000000000..8f062f9b9c1a
--- /dev/null
+++ b/app-text/gtranslator/gtranslator-2.91.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="An enhanced gettext po file editor for GNOME"
+HOMEPAGE="http://gtranslator.sourceforge.net/"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="gnome spell"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.4.2:3
+ >=x11-libs/gtksourceview-3.0.0:3.0
+ >=dev-libs/gdl-3.6:3=
+ >=dev-libs/libxml2-2.4.12:2
+ >=dev-libs/json-glib-0.12.0
+ >=dev-libs/libpeas-1.2[gtk]
+ gnome-extra/libgda:5=
+ >=app-text/iso-codes-0.35
+
+ gnome-base/gsettings-desktop-schemas
+
+ gnome? (
+ ${PYTHON_DEPS}
+ || ( app-dicts/gnome-dictionary =gnome-extra/gnome-utils-3.2* )
+ x11-libs/gtk+:3[introspection] )
+ spell? ( app-text/gtkspell:3= )"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+ gnome? (
+ >=dev-libs/libpeas-1.2[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-extra/gucharmap:2.90[introspection] )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+# eautoreconf requires gnome-base/gnome-common, app-text/yelp-tools
+
+pkg_setup() {
+ use gnome && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog HACKING INSTALL NEWS README THANKS"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_with gnome dictionary)
+ $(use_enable gnome introspection)
+ $(use_with spell gtkspell3)
+ ITSTOOL=$(type -P true)"
+
+ gnome2_src_prepare
+
+ if ! use gnome; then
+ # don't install charmap plugin, it requires gnome-extra/gucharmap
+ sed -e 's:\scharmap\s: :g' -i plugins/Makefile.* ||
+ die "sed plugins/Makefile.* failed"
+ fi
+}
diff --git a/app-text/gtranslator/gtranslator-2.91.7.ebuild b/app-text/gtranslator/gtranslator-2.91.7.ebuild
new file mode 100644
index 000000000000..e42c056cdc55
--- /dev/null
+++ b/app-text/gtranslator/gtranslator-2.91.7.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="An enhanced gettext po file editor for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gtranslator"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="gnome spell"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2[dbus]
+ >=x11-libs/gtk+-3.4.2:3
+ >=x11-libs/gtksourceview-3.0.0:3.0
+ >=dev-libs/gdl-3.6:3=
+ >=dev-libs/libxml2-2.4.12:2
+ >=dev-libs/json-glib-0.12.0
+ >=dev-libs/libpeas-1.2[gtk]
+ gnome-extra/libgda:5=
+ >=app-text/iso-codes-0.35
+
+ gnome-base/gsettings-desktop-schemas
+
+ gnome? (
+ ${PYTHON_DEPS}
+ app-dicts/gnome-dictionary:=
+ x11-libs/gtk+:3[introspection] )
+ spell? ( app-text/gtkspell:3= )
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+ gnome? (
+ >=dev-libs/libpeas-1.2[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-extra/gucharmap:2.90[introspection] )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.50.1
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+# eautoreconf requires gnome-base/gnome-common, app-text/yelp-tools
+
+pkg_setup() {
+ use gnome && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog HACKING INSTALL NEWS README THANKS"
+
+ gnome2_src_prepare
+
+ if ! use gnome; then
+ # don't install charmap plugin, it requires gnome-extra/gucharmap
+ sed -e 's:\scharmap\s: :g' -i plugins/Makefile.* ||
+ die "sed plugins/Makefile.* failed"
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with gnome dictionary) \
+ $(use_enable gnome introspection) \
+ $(use_with spell gtkspell)
+}
diff --git a/app-text/gtranslator/metadata.xml b/app-text/gtranslator/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/app-text/gtranslator/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>