summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-31 00:37:24 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-31 00:37:24 -0400
commit16d574c25258e8578a33bbb0b864156f6bdb06ba (patch)
tree58ea64a9d568d1ae53af8f30fc9dcd92e9a709ad /app-vim/gist/gist-7.3.ebuild
parentapp-vim/nerdcommenter: version bump to 2.4.0 (diff)
downloadgentoo-16d574c25258e8578a33bbb0b864156f6bdb06ba.tar.gz
gentoo-16d574c25258e8578a33bbb0b864156f6bdb06ba.tar.bz2
gentoo-16d574c25258e8578a33bbb0b864156f6bdb06ba.zip
app-vim/gist: version bump to 7.3
Diffstat (limited to 'app-vim/gist/gist-7.3.ebuild')
-rw-r--r--app-vim/gist/gist-7.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/gist/gist-7.3.ebuild b/app-vim/gist/gist-7.3.ebuild
new file mode 100644
index 000000000000..8ba3f100501f
--- /dev/null
+++ b/app-vim/gist/gist-7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=gist-vim
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2423 https://github.com/mattn/gist-vim"
+SRC_URI="https://github.com/mattn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+RDEPEND="
+ app-vim/webapi
+ net-misc/curl
+ dev-vcs/git
+"
+
+VIM_PLUGIN_HELPFILES="Gist.vim"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ rm README.md gist.vim* Makefile || die
+}