summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-04-18 22:40:25 +0200
committerTupone Alfredo <tupone@gentoo.org>2017-04-18 22:40:25 +0200
commit3968fbe1a801e276a36abce16bf412792f7b3fe8 (patch)
treed36e4f95047305bb126d63b1d15f5961a707a26e /dev-ada
parentdev-util/radare2: bump up to 1.4.0 (diff)
downloadgentoo-3968fbe1a801e276a36abce16bf412792f7b3fe8.tar.gz
gentoo-3968fbe1a801e276a36abce16bf412792f7b3fe8.tar.bz2
gentoo-3968fbe1a801e276a36abce16bf412792f7b3fe8.zip
dev-ada/gnatcoll: port to python-single-r1. Bug #615914
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch9
-rw-r--r--dev-ada/gnatcoll/gnatcoll-2016.ebuild22
2 files changed, 21 insertions, 10 deletions
diff --git a/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch b/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch
index bb2112a058fc..e69b6e50a90e 100644
--- a/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch
+++ b/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch
@@ -101,6 +101,15 @@
package Linker is
--- gnatcoll-gpl-2016-src/gnatcoll_shared.gpr.in.old 2017-01-20 19:50:03.222808656 +0100
+++ gnatcoll-gpl-2016-src/gnatcoll_shared.gpr.in 2017-01-20 19:50:28.200399274 +0100
+@@ -13,7 +13,7 @@
+
+ type Yes_No is ("yes", "no");
+ Gtk : Yes_No := External ("GTK", "@WITH_GTK@");
+- Python : Yes_No := External ("PYTHON", "@WITH_PYTHON@");
++ Python : Yes_No := "@WITH_PYTHON@";
+ Syslog : Yes_No := External ("SYSLOG", "@WITH_SYSLOG@");
+ Postgres : Yes_No := External ("POSTGRES", "@WITH_POSTGRES@");
+ type Sqlite_Inclusion is ("yes", "no", "embedded");
@@ -67,7 +67,7 @@
when "Production" =>
diff --git a/dev-ada/gnatcoll/gnatcoll-2016.ebuild b/dev-ada/gnatcoll/gnatcoll-2016.ebuild
index 36e52edb1219..b4db44c4c214 100644
--- a/dev-ada/gnatcoll/gnatcoll-2016.ebuild
+++ b/dev-ada/gnatcoll/gnatcoll-2016.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-inherit multilib multiprocessing autotools
+PYTHON_COMPAT=( python2_7 )
+inherit multilib multiprocessing autotools python-single-r1
MYP=${PN}-gpl-${PV}
@@ -20,20 +20,18 @@ RDEPEND="dev-lang/gnat-gpl
gmp? ( dev-libs/gmp:* )
postgresql? ( dev-db/postgresql:* )
pygobject? (
- || (
- dev-python/pygobject:2
- dev-python/pygobject:3
- )
+ dev-python/pygobject:*[${PYTHON_USEDEP}]
)
- python? ( dev-lang/python:2.7 )
+ python? ( ${PYTHON_DEPS} )
sqlite? ( dev-db/sqlite )
projects? (
- dev-ada/gprbuild[static?]
- dev-ada/gprbuild[shared?]
+ dev-ada/gprbuild[static?,shared?]
)"
DEPEND="${RDEPEND}
dev-ada/gprbuild"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
S="${WORKDIR}"/${MYP}-src
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
@@ -48,10 +46,12 @@ pkg_setup() {
eerror "2) set ADA=gcc-4.9.4 in make.conf"
die "ada compiler not available"
fi
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
default
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -74,7 +74,7 @@ src_configure() {
$(use_enable readline gpl) \
$(use_enable readline) \
$(use_enable syslog) \
- --with-python-exec=python2 \
+ --with-python-exec=${EPYTHON} \
--enable-shared-python \
--without-gtk \
--disable-pygtk \
@@ -102,6 +102,8 @@ src_install() {
dodoc -r features-* known-problems-* examples
mv "${D}"/usr/share/doc/${PN}/GNATColl.pdf "${D}"/usr/share/doc/${PF}/
mv "${D}"/usr/share/doc/${PN}/html/html "${D}"/usr/share/doc/${PF}/
+ rm -rf "${D}"/usr/share/doc/${PN}
+ use python && python_fix_shebang "${ED}"usr/share/gnatcoll/dborm.py
}
src_test() {