summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-04-26 20:32:51 +0200
committerTupone Alfredo <tupone@gentoo.org>2017-04-26 20:32:51 +0200
commite2658d94c1c8d71269824863f5d523f52597f448 (patch)
treed2c4fcb95eff296bb4ea8920835001de4d2c1a0e /dev-ada
parentsys-apps/policycoreutils: patches merge upstream (diff)
downloadgentoo-e2658d94c1c8d71269824863f5d523f52597f448.tar.gz
gentoo-e2658d94c1c8d71269824863f5d523f52597f448.tar.bz2
gentoo-e2658d94c1c8d71269824863f5d523f52597f448.zip
dev-ada/aunit: Add dev-ada/aunit-2016
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/aunit/Manifest1
-rw-r--r--dev-ada/aunit/aunit-2016.ebuild39
-rw-r--r--dev-ada/aunit/files/aunit-2016-gentoo.patch11
-rw-r--r--dev-ada/aunit/metadata.xml11
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ada/aunit/Manifest b/dev-ada/aunit/Manifest
new file mode 100644
index 000000000000..1214b1a5bfe1
--- /dev/null
+++ b/dev-ada/aunit/Manifest
@@ -0,0 +1 @@
+DIST aunit-gpl-2016-src.tar.gz 393489 SHA256 ba1b86b853daef98190a7dfc9858aedcd4cc85219b310356c02348f32dcc77cf SHA512 94721f04ff721bbb572ede3fe7b8b61f9682ecaec8076eec3a0a27a41d9bab86248921671b7e63656f473f8d4ddb3a44ecdfb19f479073cf2ae378d62dc68190 WHIRLPOOL fae3579197384972872966b16022e0248d23d207a55af63c6e9daf94ba152a403fa2164a7d9b81fb3ba1214583f2b5506acd87708ffb16f7ef4c66d1f14a3e13
diff --git a/dev-ada/aunit/aunit-2016.ebuild b/dev-ada/aunit/aunit-2016.ebuild
new file mode 100644
index 000000000000..9bd4322f043c
--- /dev/null
+++ b/dev-ada/aunit/aunit-2016.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multiprocessing
+
+MYP=${PN}-gpl-${PV}-src
+
+DESCRIPTION="Ada unit testing framework"
+HOMEPAGE="http://libre.adacore.com/tools/aunit/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/573990c6c7a447658d00e1cb -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/gnat-gpl"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ emake GPRBUILD="gprbuild -j$(makeopts_jobs)"
+}
+
+src_install() {
+ emake INSTALL="${D}"usr install
+ einstalldocs
+ mv "${D}"usr/share/doc/${PN}/* "${D}"usr/share/doc/${PF}/ || die
+ rmdir "${D}"usr/share/doc/${PN} || die
+ mv "${D}"usr/share/examples/${PN} "${D}"usr/share/doc/${PF}/examples || die
+ rmdir "${D}"usr/share/examples || die
+ dodoc features-* known-problems-*
+}
diff --git a/dev-ada/aunit/files/aunit-2016-gentoo.patch b/dev-ada/aunit/files/aunit-2016-gentoo.patch
new file mode 100644
index 000000000000..eeace666b45e
--- /dev/null
+++ b/dev-ada/aunit/files/aunit-2016-gentoo.patch
@@ -0,0 +1,11 @@
+--- aunit-3.8.0w-src/Makefile.old 2017-01-04 18:13:29.634899987 +0100
++++ aunit-3.8.0w-src/Makefile 2017-01-04 18:15:59.013219503 +0100
+@@ -29,7 +29,7 @@
+ .PHONY: all clean targets install_clean install
+
+ all:
+- $(GPRBUILD) -p $(GPROPTS) lib/gnat/aunit.gpr
++ $(GPRBUILD) -p $(GPROPTS) lib/gnat/aunit.gpr -cargs $(ADAFLAGS)
+
+ clean-lib:
+ $(RM) -fr lib/aunit lib/aunit-obj
diff --git a/dev-ada/aunit/metadata.xml b/dev-ada/aunit/metadata.xml
new file mode 100644
index 000000000000..355af3380ecb
--- /dev/null
+++ b/dev-ada/aunit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ AUnit is a set of Ada packages based on the xUnit family of unit test frameworks. It’s intended as a developer’s tool to facilitate confident writing and evolution of Ada software. It is purposely lightweight, as one of its main goals is to make it easy to develop and run unit tests, rather than to generate artifacts for process management. The framework supports easy composition of sets of unit tests to provide flexibility in determining what tests to run for a given purpose.
+ </longdescription>
+</pkgmetadata>