summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-04 04:11:10 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-04 04:11:10 -0500
commit05d4203bd3dd733cf76364fdb013a6b9eeef8b6b (patch)
tree2723aa5fc206b89e2e12e15c738ca7a5ae330b6b /dev-cpp/gtest
parentdev-cpp/glog: version bump to 0.3.5 #634368 (diff)
downloadgentoo-05d4203bd3dd733cf76364fdb013a6b9eeef8b6b.tar.gz
gentoo-05d4203bd3dd733cf76364fdb013a6b9eeef8b6b.tar.bz2
gentoo-05d4203bd3dd733cf76364fdb013a6b9eeef8b6b.zip
dev-cpp/gtest: merge live git ebuild w/releases & fix building w/latest git
Diffstat (limited to 'dev-cpp/gtest')
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 47a3ca79f6ee..a4ab55ca6f1e 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -1,16 +1,24 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
# Python is required for tests and some build tasks.
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-inherit git-r3 python-any-r1 cmake-multilib
+inherit python-any-r1 cmake-multilib
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/googletest"
+else
+ SRC_URI="https://github.com/google/googletest/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+ S="${WORKDIR}"/googletest-release-${PV}
+fi
DESCRIPTION="Google C++ Testing Framework"
HOMEPAGE="https://github.com/google/googletest"
-EGIT_REPO_URI="https://github.com/google/googletest.git"
LICENSE="BSD"
SLOT="0"
@@ -20,8 +28,7 @@ DEPEND="test? ( ${PYTHON_DEPS} )"
RDEPEND="!dev-cpp/gmock"
PATCHES=(
- "${FILESDIR}"/${P}-fix-py-tests.patch
- "${FILESDIR}"/${P}-fix-gcc6-undefined-behavior.patch
+ "${FILESDIR}"/${PN}-9999-fix-gcc6-undefined-behavior.patch
)
pkg_setup() {