summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/libxmlpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/libxmlpp')
-rw-r--r--dev-cpp/libxmlpp/Manifest3
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.36.0-r1.ebuild36
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.36.0.ebuild37
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.38.0.ebuild39
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.38.1.ebuild38
-rw-r--r--dev-cpp/libxmlpp/metadata.xml5
6 files changed, 158 insertions, 0 deletions
diff --git a/dev-cpp/libxmlpp/Manifest b/dev-cpp/libxmlpp/Manifest
new file mode 100644
index 000000000000..b6f702861219
--- /dev/null
+++ b/dev-cpp/libxmlpp/Manifest
@@ -0,0 +1,3 @@
+DIST libxml++-2.36.0.tar.xz 861456 SHA256 bfdf327bf9ebd12946b7aa6a152045f209d5c9fecd06ebfcdf9b3e7c1af6e2e1 SHA512 52372b3a969dc4a16d1ec70275e3c97ac20acc14703a2875ba41d1eb8fe3f318c10e02d601ceac1a0d35f47e7d7033ebd5e87c122db6b373e847d543eddbe9a6 WHIRLPOOL 19804748859cbf6144e56f1ee1746cf2b30995c70e5f74a0dd3b51b38982832a9ece6a519f43e83dca424110f98bd86e8d3d4120ce8ac59b4b837f2d4f132bba
+DIST libxml++-2.38.0.tar.xz 940844 SHA256 5698b03f5d320fb8310e30780e328f03debca12c557434ee031aea9baf3b1346 SHA512 539ea25b2e1f871dc0c06e4033659a3d6ee5bd3cb54f625ba47b0f8a8dead049602c5d28369a497c52f48f370625d5da1b187ef542fbdd2e54fd907b308cfc67 WHIRLPOOL 4056f4dedf27a6b52623bb070fc106a165d3a3f97b39e2c0f00ce2673f7901c6653c9c48ad5171b86bf8bbb9335baead8e7e0630adbefc13899dcf342c428677
+DIST libxml++-2.38.1.tar.xz 947556 SHA256 882529189b03db6c69925b3f579ab1941feb4f02b5fe2612504ee7e498a4a05f SHA512 d60f283ca2a056bf81fd6083c10dd9d469bb62dcb06ded9ea3549bc1d0053ed14f47bd86394761825f69d9d0f3a02781f1fd121244b9ce8f9637ad21e0d177f8 WHIRLPOOL 92b4222bd1626e4e5baa6dbf1ff8479a594a49fe04bbc3279e1c2da41dd0c6e12b57e5d5eaa295f3f6361af53f2288eb9e2cb31dbdbd8e781178717327a5069c
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.36.0-r1.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.36.0-r1.ebuild
new file mode 100644
index 000000000000..d26934cebcad
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.36.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_ORG_MODULE="${PN/pp/++}"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/libxml2-2.7.3[${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.32[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+multilib_src_prepare() {
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable doc documentation)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.36.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.36.0.ebuild
new file mode 100644
index 000000000000..171440d8d9cd
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.36.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_ORG_MODULE="${PN/pp/++}"
+
+inherit gnome2
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/libxml2-2.7.3
+ >=dev-cpp/glibmm-2.32"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog NEWS README*"
+ G2CONF="${G2CONF} $(use_enable doc documentation)"
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm -fr "${ED}"usr/share/doc/libxml++*
+ use doc && dohtml docs/reference/html/*
+}
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.38.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.38.0.ebuild
new file mode 100644
index 000000000000..54a7c88b713c
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.38.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+#GNOME2_LA_PUNT="yes"
+GNOME_ORG_MODULE="${PN/pp/++}"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.7.3[${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.32[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+multilib_src_prepare() {
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable doc documentation)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.38.1.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.38.1.ebuild
new file mode 100644
index 000000000000..c14533256cd3
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.38.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_ORG_MODULE="${PN/pp/++}"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.7.7[${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.32[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+multilib_src_prepare() {
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable doc documentation)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-cpp/libxmlpp/metadata.xml b/dev-cpp/libxmlpp/metadata.xml
new file mode 100644
index 000000000000..57c9d9c1a1d8
--- /dev/null
+++ b/dev-cpp/libxmlpp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-mm</herd>
+</pkgmetadata>