summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/barman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/barman')
-rw-r--r--dev-db/barman/Manifest2
-rw-r--r--dev-db/barman/barman-1.4.0.ebuild26
-rw-r--r--dev-db/barman/barman-1.4.1.ebuild26
-rw-r--r--dev-db/barman/metadata.xml8
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-db/barman/Manifest b/dev-db/barman/Manifest
new file mode 100644
index 000000000000..7cda572d30f1
--- /dev/null
+++ b/dev-db/barman/Manifest
@@ -0,0 +1,2 @@
+DIST barman-1.4.0.tar.gz 120590 SHA256 d18c331bd6d8931bd60dab272bc9d512eb494bfddb11964d7ca430f51b7e45e9 SHA512 415fd5597df94fb43b8c48ec1250c22e6bbe21217fe9937d6c0cf6ef8ab68bea21b9341c18a2e97f7af92b516f0201b82fa1279af6994d6fa60d441d3f9326e2 WHIRLPOOL 6e1e1c112ad5ef1afc76369d0f4428128ce85d2abe4a298b2eed73efc6bd2e248dd81baa3f6839360ea162dc676103f4e59f13fefe102ea609455e1330444e93
+DIST barman-1.4.1.tar.gz 122048 SHA256 38a649ab1cea811e2db9410d87c08423beb3135f88b1160913bcb9f16a10b1df SHA512 3f6d55ceee55efc95d526848292f68c80bbee4081fc26714b0da52990e3a05030ae2f89561a4c4c71c273bb1c07f009dc0bbbbebbc5cde87831b514e918ad531 WHIRLPOOL 8f42844f5d9514b0d8c14ff2ad03f1e8e3994e0e394e7e7a761b0a95ed6a8c9a4eea791a82a14b346cbcf3354aaa8f56547290eddc75ea0f57e775a55db70499
diff --git a/dev-db/barman/barman-1.4.0.ebuild b/dev-db/barman/barman-1.4.0.ebuild
new file mode 100644
index 000000000000..d312a7ea25b1
--- /dev/null
+++ b/dev-db/barman/barman-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+PYTHON_COMPAT=( python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+
+HOMEPAGE="http://www.pgbarman.org"
+SRC_URI="http://downloads.sourceforge.net/project/pgbarman/${PV}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="dev-python/argh[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]"
+DEPEND=""
diff --git a/dev-db/barman/barman-1.4.1.ebuild b/dev-db/barman/barman-1.4.1.ebuild
new file mode 100644
index 000000000000..d312a7ea25b1
--- /dev/null
+++ b/dev-db/barman/barman-1.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+PYTHON_COMPAT=( python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+
+HOMEPAGE="http://www.pgbarman.org"
+SRC_URI="http://downloads.sourceforge.net/project/pgbarman/${PV}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="dev-python/argh[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]"
+DEPEND=""
diff --git a/dev-db/barman/metadata.xml b/dev-db/barman/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/dev-db/barman/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>