summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-25 22:27:16 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-10 21:34:03 +0100
commite82963f83a9027ae6da34734a5bb7c21e152c58a (patch)
treed1172041d6a212f66d733ce1692cfce75c25e74a /dev-db/firebird
parentapp-text/libabw: Switch to https (diff)
downloadgentoo-e82963f83a9027ae6da34734a5bb7c21e152c58a.tar.gz
gentoo-e82963f83a9027ae6da34734a5bb7c21e152c58a.tar.bz2
gentoo-e82963f83a9027ae6da34734a5bb7c21e152c58a.zip
dev-db/firebird: Fix building with GCC-6
Closes: https://bugs.gentoo.org/608294 Closes: https://github.com/gentoo/gentoo/pull/5212 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-db/firebird')
-rw-r--r--dev-db/firebird/files/firebird-2.5.7.27050.0-gcc6.patch35
-rw-r--r--dev-db/firebird/firebird-2.5.7.27050.0.ebuild5
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-db/firebird/files/firebird-2.5.7.27050.0-gcc6.patch b/dev-db/firebird/files/firebird-2.5.7.27050.0-gcc6.patch
new file mode 100644
index 000000000000..f051ea02b4ce
--- /dev/null
+++ b/dev-db/firebird/files/firebird-2.5.7.27050.0-gcc6.patch
@@ -0,0 +1,35 @@
+Bug: https://bugs.gentoo.org/608294
+PR: https://github.com/FirebirdSQL/firebird/pull/104
+
+--- a/src/common/classes/alloc.h
++++ b/src/common/classes/alloc.h
+@@ -498,10 +498,14 @@ using Firebird::MemoryPool;
+
+ inline static MemoryPool* getDefaultMemoryPool() { return Firebird::MemoryPool::processMemoryPool; }
+
++#if (( ! __GNUC__ ) || ( __GNUC__ < 6 ))
++
+ // Global versions of operators new and delete
+ void* operator new(size_t s) THROW_BAD_ALLOC;
+ void* operator new[](size_t s) THROW_BAD_ALLOC;
+
++#endif
++
+ void operator delete(void* mem) throw();
+ void operator delete[](void* mem) throw();
+
+--- a/src/dudley/exe.epp
++++ b/src/dudley/exe.epp
+@@ -2884,9 +2884,9 @@ static USHORT get_prot_mask( const TEXT * relation, TEXT * field)
+ blr_parameter, 0, 0, 0,
+ blr_parameter, 0, 1, 0,
+ blr_parameter, 1, 0, 0,
+- blr_end,
+- blr_end,
+- blr_end,
++ static_cast<SCHAR>(blr_end),
++ static_cast<SCHAR>(blr_end),
++ static_cast<SCHAR>(blr_end),
+ blr_eoc
+ };
+ static FB_API_HANDLE req_handle; \ No newline at end of file
diff --git a/dev-db/firebird/firebird-2.5.7.27050.0.ebuild b/dev-db/firebird/firebird-2.5.7.27050.0.ebuild
index b118e34f5f20..b6e56990fd82 100644
--- a/dev-db/firebird/firebird-2.5.7.27050.0.ebuild
+++ b/dev-db/firebird/firebird-2.5.7.27050.0.ebuild
@@ -35,7 +35,10 @@ RDEPEND="${CDEPEND}
RESTRICT="userpriv"
-PATCHES=( "${FILESDIR}"/${PN}-2.5.3.26780.0-deps-flags.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.3.26780.0-deps-flags.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
S="${WORKDIR}/${MY_P}"