summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-22 21:47:17 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-22 22:03:03 +0100
commit3f6c102dc3d0d6454b7477d8a328b1995a3d432a (patch)
tree91aa99c2b1a883ddcb5a05d30839ee084b36f19d /dev-db/go-etcd
parentapp-vim/youcompleteme: Use egit_clean to clean workdir (diff)
downloadgentoo-3f6c102dc3d0d6454b7477d8a328b1995a3d432a.tar.gz
gentoo-3f6c102dc3d0d6454b7477d8a328b1995a3d432a.tar.bz2
gentoo-3f6c102dc3d0d6454b7477d8a328b1995a3d432a.zip
dev-db/go-etcd: Use egit_clean to clean workdir
* Sort global scope according to skel.ebuild Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-db/go-etcd')
-rw-r--r--dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild14
-rw-r--r--dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild16
-rw-r--r--dev-db/go-etcd/go-etcd-2.0.0.ebuild18
3 files changed, 31 insertions, 17 deletions
diff --git a/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild b/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild
index 8ea0f6d7fd64..15b9646986a9 100644
--- a/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild
+++ b/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild
@@ -1,20 +1,24 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-KEYWORDS="~amd64"
-DESCRIPTION="Go client library for etcd"
+inherit eutils
GO_PN=github.com/coreos/${PN}
+DESCRIPTION="Go client library for etcd"
HOMEPAGE="https://${GO_PN}"
EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
+
SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
IUSE=""
+
DEPEND=">=dev-lang/go-1.4"
RDEPEND=""
+
S=${WORKDIR}
src_unpack() {
@@ -38,6 +42,6 @@ src_install() {
insinto /usr/lib/go
doins -r pkg
insinto /usr/lib/go/src
- find src/${GO_PN} -name .gitignore -delete
+ egit_clean
doins -r src/*
}
diff --git a/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild b/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild
index 79358b57b672..9cf4459eb49d 100644
--- a/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild
+++ b/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild
@@ -1,20 +1,24 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-KEYWORDS="~amd64"
-DESCRIPTION="Go client library for etcd"
GO_PN=github.com/coreos/${PN}
-HOMEPAGE="https://${GO_PN}"
EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
+
+DESCRIPTION="Go client library for etcd"
+HOMEPAGE="https://${GO_PN}"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
+
SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
IUSE=""
+
DEPEND=">=dev-lang/go-1.4:="
RDEPEND=""
+
S=${WORKDIR}
src_unpack() {
@@ -38,6 +42,6 @@ src_install() {
insinto /usr/lib/go
doins -r pkg
insinto /usr/lib/go/src
- find src/${GO_PN} -name .gitignore -delete
+ egit_clean
doins -r src/*
}
diff --git a/dev-db/go-etcd/go-etcd-2.0.0.ebuild b/dev-db/go-etcd/go-etcd-2.0.0.ebuild
index 8ea0f6d7fd64..5139a5578eb7 100644
--- a/dev-db/go-etcd/go-etcd-2.0.0.ebuild
+++ b/dev-db/go-etcd/go-etcd-2.0.0.ebuild
@@ -1,20 +1,26 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-KEYWORDS="~amd64"
-DESCRIPTION="Go client library for etcd"
+inherit eutils
+
GO_PN=github.com/coreos/${PN}
-HOMEPAGE="https://${GO_PN}"
EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
+
+DESCRIPTION="Go client library for etcd"
+HOMEPAGE="https://${GO_PN}"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
+
SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
IUSE=""
+
DEPEND=">=dev-lang/go-1.4"
RDEPEND=""
+
S=${WORKDIR}
src_unpack() {
@@ -38,6 +44,6 @@ src_install() {
insinto /usr/lib/go
doins -r pkg
insinto /usr/lib/go/src
- find src/${GO_PN} -name .gitignore -delete
+ egit_clean
doins -r src/*
}