summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2017-11-22 18:19:38 +0100
committerRobin H. Johnson <robbat2@gentoo.org>2017-11-23 14:21:13 -0800
commit1549caced8940fffc49201959ade20270dc89d87 (patch)
tree50c63c0063fd30fdec6a57c6883815831a8523a1 /dev-db/redis
parentmedia-sound/guayadeque: add live ebuild to track upstream dev. (diff)
downloadgentoo-1549caced8940fffc49201959ade20270dc89d87.tar.gz
gentoo-1549caced8940fffc49201959ade20270dc89d87.tar.bz2
gentoo-1549caced8940fffc49201959ade20270dc89d87.zip
dev-db/redis: remove unused patches
Fixes: https://github.com/gentoo/gentoo/pull/6261 (cherry picked from commit 870779cd6f1a6bc312c2d3772e9d067b8c057d18) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-db/redis')
-rw-r--r--dev-db/redis/files/redis-3.2.0-config.patch37
-rw-r--r--dev-db/redis/files/redis-3.2.0-sharedlua.patch36
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-db/redis/files/redis-3.2.0-config.patch b/dev-db/redis/files/redis-3.2.0-config.patch
deleted file mode 100644
index 8d93a0e7b62a..000000000000
--- a/dev-db/redis/files/redis-3.2.0-config.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/redis.conf 2016-05-06 09:11:36.000000000 +0200
-+++ b/redis.conf 2016-06-14 09:20:05.980855432 +0200
-@@ -146,7 +146,7 @@
- #
- # Creating a pid file is best effort: if Redis is not able to create it
- # nothing bad happens, the server will start and run normally.
--pidfile /var/run/redis.pid
-+pidfile /run/redis/redis.pid
-
- # Specify the server verbosity level.
- # This can be one of:
-@@ -159,7 +159,7 @@
- # Specify the log file name. Also the empty string can be used to force
- # Redis to log on the standard output. Note that if you use standard
- # output for logging but daemonize, logs will be sent to /dev/null
--logfile ""
-+logfile /var/log/redis/redis.log
-
- # To enable logging to the system logger, just set 'syslog-enabled' to yes,
- # and optionally update the other syslog parameters to suit your needs.
-@@ -243,7 +243,7 @@
- # The Append Only File will also be created inside this directory.
- #
- # Note that you must specify a directory here, not a file name.
--dir ./
-+dir /var/lib/redis/
-
- ################################# REPLICATION #################################
-
-@@ -505,6 +505,7 @@
- # output buffers (but this is not needed if the policy is 'noeviction').
- #
- # maxmemory <bytes>
-+maxmemory 67108864
-
- # MAXMEMORY POLICY: how Redis will select what to remove when maxmemory
- # is reached. You can select among five behaviors:
diff --git a/dev-db/redis/files/redis-3.2.0-sharedlua.patch b/dev-db/redis/files/redis-3.2.0-sharedlua.patch
deleted file mode 100644
index 248e990cf59c..000000000000
--- a/dev-db/redis/files/redis-3.2.0-sharedlua.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/src/Makefile 2016-06-14 09:21:51.613721601 +0200
-+++ b/src/Makefile 2016-06-14 09:25:21.262442026 +0200
-@@ -15,7 +15,7 @@
- release_hdr := $(shell sh -c './mkreleasehdr.sh')
- uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
- OPTIMIZATION?=-O2
--DEPENDENCY_TARGETS=hiredis linenoise lua geohash-int
-+DEPENDENCY_TARGETS=hiredis linenoise geohash-int
-
- # Default settings
- STD=-std=c99 -pedantic -DREDIS_STATIC=''
-@@ -51,6 +51,7 @@
- FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS) -I../deps/geohash-int
- FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
- FINAL_LIBS=-lm
-+FINAL_LIBS+=$(shell pkg-config --libs lua)
- DEBUG=-g -ggdb
-
- ifeq ($(uname_S),SunOS)
-@@ -112,6 +113,7 @@
- REDIS_SERVER_NAME=redis-server
- REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o geo.o
-+REDIS_SERVER_OBJ+=fpconv.o strbuf.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o
- REDIS_GEOHASH_OBJ=../deps/geohash-int/geohash.o ../deps/geohash-int/geohash_helper.o
- REDIS_CLI_NAME=redis-cli
- REDIS_CLI_OBJ=anet.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
-@@ -166,7 +168,7 @@
-
- # redis-server
- $(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
-- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(REDIS_GEOHASH_OBJ) $(FINAL_LIBS)
-+ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(REDIS_GEOHASH_OBJ) $(FINAL_LIBS)
-
- # redis-sentinel
- $(REDIS_SENTINEL_NAME): $(REDIS_SERVER_NAME)