summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/tinycdb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/tinycdb')
-rw-r--r--dev-db/tinycdb/Manifest1
-rw-r--r--dev-db/tinycdb/files/tinycdb-0.77-gentoo.diff28
-rw-r--r--dev-db/tinycdb/files/tinycdb-0.77-uclibc.diff15
-rw-r--r--dev-db/tinycdb/files/tinycdb-0.77-umask.diff11
-rw-r--r--dev-db/tinycdb/metadata.xml7
-rw-r--r--dev-db/tinycdb/tinycdb-0.77-r2.ebuild49
6 files changed, 111 insertions, 0 deletions
diff --git a/dev-db/tinycdb/Manifest b/dev-db/tinycdb/Manifest
new file mode 100644
index 000000000000..5df65975a249
--- /dev/null
+++ b/dev-db/tinycdb/Manifest
@@ -0,0 +1 @@
+DIST tinycdb_0.77.tar.gz 37728 SHA256 82bc3ccf0afed0978472a070ce4506667b8035e65d0dc24388e33858d39b6bc6 SHA512 cfc830578a9be49781a1dbade97b64ec13293853093719aeb9a403c128245f157fd1d2d7e6941966bdea00b472127f10f11672583ba06ccc6e49151b22bf4c9a WHIRLPOOL d9e0b94932a0455660f5fe8bac1fbbe79dc5774c3742a135c2543d5ce698cea077191ea135465930c017ed20601f65d85b86f614b5814cb4d741198ada55660f
diff --git a/dev-db/tinycdb/files/tinycdb-0.77-gentoo.diff b/dev-db/tinycdb/files/tinycdb-0.77-gentoo.diff
new file mode 100644
index 000000000000..87ab43ff5c82
--- /dev/null
+++ b/dev-db/tinycdb/files/tinycdb-0.77-gentoo.diff
@@ -0,0 +1,28 @@
+--- tinycdb-0.77.orig/Makefile
++++ tinycdb-0.77/Makefile
+@@ -34,7 +34,7 @@
+ CDB_USELIB = $(LIB)
+ NSS_USELIB = $(PICLIB)
+ LIBMAP = $(LIBBASE).map
+-INSTALLPROG = cdb
++INSTALLPROG = cdb-shared
+
+ # The following assumes GNU CC/LD -
+ # used for building shared libraries only
+@@ -59,7 +59,7 @@
+ ChangeLog NEWS
+ DEBIANFILES = debian/control debian/rules debian/copyright debian/changelog
+
+-all: static
++all: shared
+ static: staticlib cdb
+ staticlib: $(LIB)
+ nss: $(NSS_CDB)
+@@ -128,6 +128,7 @@
+
+ do_install = \
+ while [ "$$1" ] ; do \
++ if [ ! -f $$1 ]; then shift 4; continue; fi; \
+ if [ .$$4 = .- ]; then f=$$1; else f=$$4; fi; \
+ d=$(DESTDIR)$$3 ; echo installing $$1 to $$d/$$f; \
+ [ -d $$d ] || mkdir -p $$d || exit 1 ; \
diff --git a/dev-db/tinycdb/files/tinycdb-0.77-uclibc.diff b/dev-db/tinycdb/files/tinycdb-0.77-uclibc.diff
new file mode 100644
index 000000000000..52240931e091
--- /dev/null
+++ b/dev-db/tinycdb/files/tinycdb-0.77-uclibc.diff
@@ -0,0 +1,15 @@
+--- tinycdb-0.77.orig/cdb.c
++++ tinycdb-0.77/cdb.c
+@@ -31,6 +31,12 @@
+ # define HAVE_PROGRAM_INVOCATION_SHORT_NAME
+ #endif
+
++#ifdef __UCLIBC__
++# ifndef __UCLIBC_HAS_PROGRAM_INVOCATION_NAME__
++# undef HAVE_PROGRAM_INVOCATION_SHORT_NAME
++# endif
++#endif
++
+ #ifdef HAVE_PROGRAM_INVOCATION_SHORT_NAME
+ # define progname program_invocation_short_name
+ #else
diff --git a/dev-db/tinycdb/files/tinycdb-0.77-umask.diff b/dev-db/tinycdb/files/tinycdb-0.77-umask.diff
new file mode 100644
index 000000000000..2a53babb2510
--- /dev/null
+++ b/dev-db/tinycdb/files/tinycdb-0.77-umask.diff
@@ -0,0 +1,11 @@
+--- a/cdb.c
++++ b/cdb.c
+@@ -21,6 +21,8 @@
+ #include <stdarg.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <sys/types.h> /* umask() */
++#include <sys/stat.h> /* umask() */
+ #include "cdb.h"
+
+ #ifndef EPROTO
diff --git a/dev-db/tinycdb/metadata.xml b/dev-db/tinycdb/metadata.xml
new file mode 100644
index 000000000000..d4a08224d284
--- /dev/null
+++ b/dev-db/tinycdb/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-db/tinycdb/tinycdb-0.77-r2.ebuild b/dev-db/tinycdb/tinycdb-0.77-r2.ebuild
new file mode 100644
index 000000000000..a1074918b4f2
--- /dev/null
+++ b/dev-db/tinycdb/tinycdb-0.77-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="TinyCDB is a very fast and simple package for creating and reading constant data bases"
+HOMEPAGE="http://www.corpit.ru/mjt/tinycdb.html"
+SRC_URI="http://www.corpit.ru/mjt/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 hppa ia64 ppc x86"
+IUSE="static-libs"
+RESTRICT="test"
+
+RDEPEND="!dev-db/cdb"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-umask.diff
+ epatch "${FILESDIR}"/${P}-uclibc.diff
+ # fix multilib support
+ sed -i "/^libdir/s:/lib:/$(get_libdir):" Makefile
+}
+
+src_compile() {
+ local targets="shared"
+ use static-libs && targets+=" staticlib piclib"
+
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ ${targets}
+}
+
+src_install() {
+ local targets="install install-sharedlib"
+ use static-libs && targets+=" install-piclib"
+
+ emake \
+ prefix="/usr" \
+ mandir="/usr/share/man" \
+ DESTDIR="${D}" \
+ ${targets}
+ dodoc ChangeLog NEWS
+}