summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/mono-nat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/mono-nat')
-rw-r--r--dev-dotnet/mono-nat/Manifest2
-rw-r--r--dev-dotnet/mono-nat/files/mono-nat.pc.in8
-rw-r--r--dev-dotnet/mono-nat/metadata.xml5
-rw-r--r--dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild42
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-dotnet/mono-nat/Manifest b/dev-dotnet/mono-nat/Manifest
new file mode 100644
index 000000000000..873848372f4c
--- /dev/null
+++ b/dev-dotnet/mono-nat/Manifest
@@ -0,0 +1,2 @@
+DIST mono-nat-1.1.0.tar.gz 79637 SHA256 34095f6524f9e6bebe0b696d76fbfcaba84cfe3ac04f811ba9d37fe14ba0bca1 SHA512 bc3aee9f31966c9726f94a89929a13d900aea27cb3dc57d6fa953f5eab4fdb36b00a3180c150f9fd5a7c2fd58c122e4b64b046e4f4b8f3ca4d6313298459985d WHIRLPOOL 262e2808aea33a7d45bbb6bde989bf2ad8afdd9107c6bddb0702bd889ae3af721af3b82359f6b2da8a433032898f893057804e103ac8a53822db1dee6256fc34
+DIST mono.snk.bz2 785 SHA256 0cc2ca58f90773eafa8460dfb8ff4ac6238b68106eb1631348a800091a6ff3de SHA512 de64da7a9e4fa53e5a5abaee00aae05ce3560c72ad8251fd79e2ff9ffa7fb2d5e7c1a4bdb2dbc2eeeeac6450aaad8c40649ff4675ddf95365ef8604a93333224 WHIRLPOOL 05882dd5cc9e2b99b78dc882fed49547dc6b6c133616574987322623e3bd734dc74435b69a6c864f928eb087df7a1ab42910adc47a7d0e70d54178e6b319f628
diff --git a/dev-dotnet/mono-nat/files/mono-nat.pc.in b/dev-dotnet/mono-nat/files/mono-nat.pc.in
new file mode 100644
index 000000000000..33d48a810842
--- /dev/null
+++ b/dev-dotnet/mono-nat/files/mono-nat.pc.in
@@ -0,0 +1,8 @@
+prefix=${pcfiledir}/../..
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@LIBDIR@
+
+Name: @PACKAGENAME@
+Description: @DESCRIPTION@
+Version: @VERSION@
+Libs: @LIBS@
diff --git a/dev-dotnet/mono-nat/metadata.xml b/dev-dotnet/mono-nat/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/dev-dotnet/mono-nat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild b/dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild
new file mode 100644
index 000000000000..8294d0494130
--- /dev/null
+++ b/dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit mono multilib
+
+MY_PN=Mono.Nat
+
+DESCRIPTION="Mono.Nat is a C# library used for automatic port forwarding, using either uPnP or nat-pmp"
+HOMEPAGE="http://projects.qnetp.net/projects/show/mono-nat"
+SRC_URI="http://projects.qnetp.net/attachments/download/76/${P}.tar.gz
+ mirror://gentoo/mono.snk.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RDEPEND=">=dev-lang/mono-2.0.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${WORKDIR}/mono.snk"
+}
+
+src_install() {
+ egacinstall $(find . -name "Mono.Nat.dll")
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${MY_PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/mono-nat/Mono.Nat.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/mono.nat.pc \
+ || die "sed failed"
+ PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists mono.nat || die ".pc file failed to validate."
+ eend $?
+}