summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-07-18 20:03:06 +0000
committerSam James <sam@gentoo.org>2020-07-18 20:03:49 +0000
commitb28d37bb050204162e4854346cc87d0960dec923 (patch)
treef5532429240ecbf122638b1dd067c4e21c0aad50 /dev-dotnet
parentsys-block/arcconf: amd64 stable (bug #724124) (diff)
downloadgentoo-b28d37bb050204162e4854346cc87d0960dec923.tar.gz
gentoo-b28d37bb050204162e4854346cc87d0960dec923.tar.bz2
gentoo-b28d37bb050204162e4854346cc87d0960dec923.zip
dev-dotnet/gtk-sharp: fix build
This is a long-standing bug with a simple patch to fix an ambiguous property reference. Closes: https://bugs.gentoo.org/697108 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/gtk-sharp/files/gtk-sharp-2.12.21-mono-ambiguous-range.patch15
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild4
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-dotnet/gtk-sharp/files/gtk-sharp-2.12.21-mono-ambiguous-range.patch b/dev-dotnet/gtk-sharp/files/gtk-sharp-2.12.21-mono-ambiguous-range.patch
new file mode 100644
index 000000000000..048373a3ec71
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/files/gtk-sharp-2.12.21-mono-ambiguous-range.patch
@@ -0,0 +1,15 @@
+https://github.com/mono/gtk-sharp/commit/a00552ad68ae349e89e440dca21b86dbd6bccd30
+https://bugs.gentoo.org/697108
+--- a/sample/test/TestRange.cs 2012-09-25 14:19:02.000000000 -0700
++++ b/sample/test/TestRange.cs 2020-07-05 09:07:25.112932811 -0700
+@@ -10,6 +10,10 @@
+
+ using Gtk;
+
++// disambiguate, Gtk.Range vs System.Range
++using Range=Gtk.Range;
++
++
+ namespace WidgetViewer {
+
+ public class TestRange
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild
index 9d011d0f9f48..91c76012d1da 100644
--- a/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild
@@ -35,6 +35,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
sys-devel/automake:1.11"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.12.21-mono-ambiguous-range.patch"
+)
+
src_prepare() {
base_src_prepare
eautoreconf