summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/gtkradiant/gtkradiant-1.5.0_pre20060302.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/gtkradiant/gtkradiant-1.5.0_pre20060302.ebuild')
-rw-r--r--dev-games/gtkradiant/gtkradiant-1.5.0_pre20060302.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-games/gtkradiant/gtkradiant-1.5.0_pre20060302.ebuild b/dev-games/gtkradiant/gtkradiant-1.5.0_pre20060302.ebuild
new file mode 100644
index 000000000000..dd09fe55299a
--- /dev/null
+++ b/dev-games/gtkradiant/gtkradiant-1.5.0_pre20060302.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils games rpm
+
+DS="${PV/*_pre}"
+DESCRIPTION="FPS level editor"
+HOMEPAGE="http://www.qeradiant.com/?data=editors/gtk"
+SRC_URI="http://zerowing.idsoftware.com/files/radiant/nightly/${PV:0:3}/gtkradiant-${PV/_pre*}-${DS:0:4}-${DS:4:2}-${DS:6:2}.i386.rpm"
+
+LICENSE="qeradiant"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+RDEPEND="=media-libs/libpng-1.2*
+ sys-libs/zlib
+ app-crypt/mhash
+ =dev-libs/glib-2*
+ x11-libs/gtk+:2
+ dev-libs/atk
+ x11-libs/pango
+ x11-libs/gtkglext
+ dev-libs/libxml2
+ sys-libs/glibc
+ virtual/opengl"
+
+S=${WORKDIR}/opt/${PN}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+ dodir "${dir}"
+
+ cp -pPR * "${D}/${dir}/"
+ games_make_wrapper q3map2 ./q3map2.x86 "${dir}"
+ games_make_wrapper radiant ./radiant.x86 "${dir}"
+
+ prepgamesdirs
+}