summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/newton
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/newton')
-rw-r--r--dev-games/newton/Manifest1
-rw-r--r--dev-games/newton/files/CMakeLists.txt58
-rw-r--r--dev-games/newton/metadata.xml5
-rw-r--r--dev-games/newton/newton-2.36.ebuild36
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-games/newton/Manifest b/dev-games/newton/Manifest
new file mode 100644
index 000000000000..e01c52f98e66
--- /dev/null
+++ b/dev-games/newton/Manifest
@@ -0,0 +1 @@
+DIST newton-dynamics-2.36.rar 65378909 SHA256 d88dd127e23ff6a5cb44021937b319ab42533f4129ee7c35a77e5e6165c0f888 SHA512 aef8ef121ebbad525b3eeb5dc4da511cd357f52388d5cbf6b9709cbad497ae91f93518dc7eccc914ecf2220428ef5935b4b3fc1500804dd016443ea0fad1c058 WHIRLPOOL 1ae7aa9ec7eb88fd74bb5f54c053871dd58da4cb0e2b8578409be302c85602a1c4950b3a752ede6be0976f1d6077f55a8d8cac5bccd96ea7371af1ea97adfed0
diff --git a/dev-games/newton/files/CMakeLists.txt b/dev-games/newton/files/CMakeLists.txt
new file mode 100644
index 000000000000..36cf0e75a4cc
--- /dev/null
+++ b/dev-games/newton/files/CMakeLists.txt
@@ -0,0 +1,58 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(Newton)
+file(GLOB NewtonLibSrc
+ ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/core/*.cpp
+ ${CMAKE_SOURCE_DIR}/packages/dCustomJoints/*.cpp
+ ${CMAKE_SOURCE_DIR}/packages/dContainers/*.cpp
+ ${CMAKE_SOURCE_DIR}/packages/dMath/*.cpp
+ #${CMAKE_SOURCE_DIR}/packages/dScene/*.cpp
+ ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/physics/*.cpp
+)
+
+file(GLOB NewtonLibH
+ ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/core/*.h
+ ${CMAKE_SOURCE_DIR}/packages/dCustomJoints/*.h
+ ${CMAKE_SOURCE_DIR}/packages/dContainers/*.h
+ ${CMAKE_SOURCE_DIR}/packages/dMath/*.h
+ #${CMAKE_SOURCE_DIR}/packages/dScene/*.h
+ ${CMAKE_SOURCE_DIR}/packages/*.h
+ ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/physics/*.h
+)
+
+file(GLOB to_remove ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/physics/dgVehicleConstraint.cpp
+)
+list(REMOVE_ITEM NewtonLibSrc ${to_remove})
+
+set(NewtonSrc ${NewtonSrc}
+ ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/newton/NewtonClass.cpp
+ ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/newton/Newton.cpp
+)
+
+set(includeDirs
+ ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/core/
+ ${CMAKE_SOURCE_DIR}/coreLibrary_200/source/physics/
+ ${CMAKE_SOURCE_DIR}/packages/dCustomJoints/
+ ${CMAKE_SOURCE_DIR}/packages/dContainers/
+ ${CMAKE_SOURCE_DIR}/packages/dMath/
+ ${CMAKE_SOURCE_DIR}/packages/dScene/
+ ${CMAKE_SOURCE_DIR}/packages/
+)
+
+include_directories(${includeDirs})
+
+add_definitions( -DJOINTLIBRARY_LIB -D_LINUX_VER )
+
+
+SET(LIB_TYPE SHARED)
+add_library(Newton ${LIB_TYPE} ${NewtonLibH} ${NewtonLibSrc} ${NewtonSrc})
+
+INSTALL(TARGETS Newton
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib
+)
+
+INSTALL(FILES ${NewtonLibH} DESTINATION include)
+
+
diff --git a/dev-games/newton/metadata.xml b/dev-games/newton/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/dev-games/newton/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/dev-games/newton/newton-2.36.ebuild b/dev-games/newton/newton-2.36.ebuild
new file mode 100644
index 000000000000..7d0b5d3d0479
--- /dev/null
+++ b/dev-games/newton/newton-2.36.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs cmake-utils unpacker
+
+MY_P="${PN}-dynamics-${PV}"
+DESCRIPTION="an integrated solution for real time simulation of physics environments"
+HOMEPAGE="http://code.google.com/p/newton-dynamics/"
+SRC_URI="http://newton-dynamics.googlecode.com/files/${MY_P}.rar"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="$(unpacker_src_uri_depends)"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt "${S}" || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=/usr/
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_install
+}