summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2016-02-24 01:15:02 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2016-02-24 01:18:45 +0100
commitc0699c6e3a394050c27ca86db20b183219e1a016 (patch)
tree6cd8b0ec4040ff6590a74307ad22f24df829fe14 /dev-games/simgear
parentdev-python/zope-event: Version bump (diff)
downloadgentoo-c0699c6e3a394050c27ca86db20b183219e1a016.tar.gz
gentoo-c0699c6e3a394050c27ca86db20b183219e1a016.tar.bz2
gentoo-c0699c6e3a394050c27ca86db20b183219e1a016.zip
games-simulation/flightgear: Add live ebuilds
Diffstat (limited to 'dev-games/simgear')
-rw-r--r--dev-games/simgear/simgear-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-games/simgear/simgear-9999.ebuild b/dev-games/simgear/simgear-9999.ebuild
new file mode 100644
index 000000000000..f1512179d7a9
--- /dev/null
+++ b/dev-games/simgear/simgear-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_WARN_UNUSED_CLI=1
+inherit eutils cmake-utils git-r3
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+EGIT_REPO_URI="git://git.code.sf.net/p/flightgear/${PN}
+ git://mapserver.flightgear.org/${PN}"
+EGIT_BRANCH="next"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+SLOT="0"
+IUSE="curl debug subversion test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ >=dev-games/openscenegraph-3.2.0
+ media-libs/openal
+ sys-libs/zlib
+ virtual/opengl
+ curl? ( net-misc/curl )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}
+ subversion? ( dev-vcs/subversion )
+"
+
+DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CURL=$(usex curl)
+ -DENABLE_PKGUTIL=ON
+ -DENABLE_RTI=OFF
+ -DENABLE_SOUND=ON
+ -DENABLE_TESTS=$(usex test)
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ )
+ cmake-utils_src_configure
+}