summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-03-21 16:55:26 +0500
committerJames Le Cuirot <chewi@gentoo.org>2018-03-25 20:51:36 +0100
commit9fa283b13aa8846ede5af588ae3aebe2154c7c05 (patch)
tree381bc42c8ff1a3a92a8141e56c3897c429537c97 /dev-games
parentdev-ruby/actionview: keyworded 4.2.10 for ppc, bug #563858 (diff)
downloadgentoo-9fa283b13aa8846ede5af588ae3aebe2154c7c05.tar.gz
gentoo-9fa283b13aa8846ede5af588ae3aebe2154c7c05.tar.bz2
gentoo-9fa283b13aa8846ede5af588ae3aebe2154c7c05.zip
dev-games/physfs: added new USE-flags
Added 7zip (Bug #381973), iso, vdf, slb file formats support, cleanup for outdated code (Bug #649456). Closes: https://bugs.gentoo.org/381973 Closes: https://bugs.gentoo.org/649456 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7532
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/physfs/metadata.xml4
-rw-r--r--dev-games/physfs/physfs-3.0.1-r1.ebuild50
-rw-r--r--dev-games/physfs/physfs-9999.ebuild35
3 files changed, 74 insertions, 15 deletions
diff --git a/dev-games/physfs/metadata.xml b/dev-games/physfs/metadata.xml
index 5bca86689c43..62272a610b69 100644
--- a/dev-games/physfs/metadata.xml
+++ b/dev-games/physfs/metadata.xml
@@ -23,9 +23,13 @@ the user's home directory, where in the real filesystem your program is running,
etc.
</longdescription>
<use>
+<flag name="7zip">Enable 7zip/lzma archive support</flag>
<flag name="grp">Enable Build Engine GRP archive support</flag>
<flag name="hog">Enable Descent I/II HOG archive support</flag>
+<flag name="iso">Enable ISO9660 file support</flag>
<flag name="mvl">Enable Descent I/II MVL archive support</flag>
+<flag name="slb">Enable Independence War SLB archive support</flag>
+<flag name="vdf">Enable Gothic/Gothic II VDF archive support</flag>
<flag name="wad">Enable Doom WAD archive support</flag>
<flag name="qpak">Enable Quake I/II QPAK archive support</flag>
<flag name="zip">Enable ZIP archive support</flag>
diff --git a/dev-games/physfs/physfs-3.0.1-r1.ebuild b/dev-games/physfs/physfs-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..237ccc126998
--- /dev/null
+++ b/dev-games/physfs/physfs-3.0.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-multilib
+
+DESCRIPTION="Abstraction layer for filesystem and archive access"
+HOMEPAGE="http://icculus.org/physfs/"
+SRC_URI="http://icculus.org/physfs/downloads/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86 ~x86-fbsd"
+IUSE="7zip doc grp hog iso mvl qpak slb static-libs vdf wad +zip"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( docs/CHANGELOG.txt docs/CREDITS.txt docs/TODO.txt )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DPHYSFS_BUILD_SHARED=ON
+ -DPHYSFS_BUILD_TEST=OFF
+ -DPHYSFS_BUILD_STATIC="$(usex static-libs)"
+ -DPHYSFS_ARCHIVE_7Z="$(usex 7zip)"
+ -DPHYSFS_ARCHIVE_GRP="$(usex grp)"
+ -DPHYSFS_ARCHIVE_HOG="$(usex hog)"
+ -DPHYSFS_ARCHIVE_ISO9660="$(usex iso)"
+ -DPHYSFS_ARCHIVE_MVL="$(usex mvl)"
+ -DPHYSFS_ARCHIVE_SLB="$(usex slb)"
+ -DPHYSFS_ARCHIVE_VDF="$(usex vdf)"
+ -DPHYSFS_ARCHIVE_WAD="$(usex wad)"
+ -DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
+ -DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+ multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use doc ; then
+ docinto html
+ dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
+ fi
+}
diff --git a/dev-games/physfs/physfs-9999.ebuild b/dev-games/physfs/physfs-9999.ebuild
index a3cfee4fd576..d001542c16ed 100644
--- a/dev-games/physfs/physfs-9999.ebuild
+++ b/dev-games/physfs/physfs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,36 +16,41 @@ fi
LICENSE="ZLIB"
SLOT="0"
-IUSE="grp hog mvl qpak static-libs wad +zip"
+IUSE="7zip doc grp hog iso mvl qpak slb static-libs vdf wad +zip"
RDEPEND=""
DEPEND=""
DOCS=( docs/CHANGELOG.txt docs/CREDITS.txt docs/TODO.txt )
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i -e 's:-Werror::' CMakeLists.txt || die
- # make sure these libs aren't used
- rm -rf lzma zlib*
-}
-
-src_configure() {
+multilib_src_configure() {
local mycmakeargs=(
- -DPHYSFS_ARCHIVE_7Z=OFF
-DPHYSFS_BUILD_SHARED=ON
-DPHYSFS_BUILD_TEST=OFF
- -DPHYSFS_BUILD_WX_TEST=OFF
- -DPHYSFS_INTERNAL_ZLIB=OFF
-DPHYSFS_BUILD_STATIC="$(usex static-libs)"
+ -DPHYSFS_ARCHIVE_7Z="$(usex 7zip)"
-DPHYSFS_ARCHIVE_GRP="$(usex grp)"
-DPHYSFS_ARCHIVE_HOG="$(usex hog)"
+ -DPHYSFS_ARCHIVE_ISO9660="$(usex iso)"
-DPHYSFS_ARCHIVE_MVL="$(usex mvl)"
+ -DPHYSFS_ARCHIVE_SLB="$(usex slb)"
+ -DPHYSFS_ARCHIVE_VDF="$(usex vdf)"
-DPHYSFS_ARCHIVE_WAD="$(usex wad)"
-DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
-DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
)
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+ multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+}
- cmake-multilib_src_configure
+multilib_src_install_all() {
+ einstalldocs
+ if use doc ; then
+ docinto html
+ dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
+ fi
}