summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-07 18:53:37 +0200
committerDavid Seifert <soap@gentoo.org>2017-01-07 21:12:27 +0200
commitf24bba3735c41f3ccb9818b000c038240425af8f (patch)
tree79292ed4f819ed63d9c5cb7903c7cb5cf9fa591a /dev-games
parentsys-apps/pcmciautils: flex-2.6.3 compatibility fix (diff)
downloadgentoo-f24bba3735c41f3ccb9818b000c038240425af8f.tar.gz
gentoo-f24bba3735c41f3ccb9818b000c038240425af8f.tar.bz2
gentoo-f24bba3735c41f3ccb9818b000c038240425af8f.zip
dev-games/clanlib: Version bump to 4.0.0
* EAPI=6 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/Manifest1
-rw-r--r--dev-games/clanlib/clanlib-4.0.0.ebuild77
-rw-r--r--dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch25
3 files changed, 103 insertions, 0 deletions
diff --git a/dev-games/clanlib/Manifest b/dev-games/clanlib/Manifest
index 4fda43feeb23..4d6f33c05c60 100644
--- a/dev-games/clanlib/Manifest
+++ b/dev-games/clanlib/Manifest
@@ -1,2 +1,3 @@
DIST ClanLib-0.8.1.tgz 7629019 SHA256 094331dda35b0d263431d1551991eb208d8e969824434925548a9fcd1d34e495 SHA512 277daaf1055ae0198be7a6bbfd415c79cfae9e2145f62553e83849d670f56e50b8484c83f8b85f23290002e0b0c72c1e01ca597ad608a0954a4add828177293b WHIRLPOOL be486125f406a307676c4957f977b6ccc6bc2ce527a72fb4febcb3d1c7e2acdc4fc6706b66b75412184c3a0744c53e962011b0c3ac22958da5e987f0fccc9d87
DIST ClanLib-2.3.7.tgz 26132425 SHA256 d46127c08103f48d15936ceb9f95b3dfb1ff8ccba667cef1b3f8e639cb2601c2 SHA512 73169afc0f639390f80403150757a8a14f842bc291a9457c9bca1319642b78bc4d03a93327d75254230e39545c5b4b690e56dc0149ed7b60b223e5a5364e882a WHIRLPOOL a6547d0bc8d254e887c427dfff63deb2b69790124da3db49d54cf853f8c834d44172a06e92ef7fc5222c8c81f903ab29f186f85da698dc085f4138d147ddad68
+DIST clanlib-4.0.0.tar.gz 7435551 SHA256 9b35052308a2b933bba76596930ab550fc8cd1f80155fc62aa648a23c3f4406f SHA512 e727239d782d2d52ce2f927e16a88c469b30f46d5b9eba4573baa520d98f60515df7ff4dd921092ddd5cfe4c6f5c441e0f33469b774287003db439feb8b027fe WHIRLPOOL b541c0dca233570f5c203269684de2a187391f35278722e81ca64b5f9fc3d61cb2f3cb615db6d4d7956369c04fbb9aea165a0ee5df0210b5bd50ab669d4fd691
diff --git a/dev-games/clanlib/clanlib-4.0.0.ebuild b/dev-games/clanlib/clanlib-4.0.0.ebuild
new file mode 100644
index 000000000000..7fa5f2d115c5
--- /dev/null
+++ b/dev-games/clanlib/clanlib-4.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+MY_PN=ClanLib
+
+DESCRIPTION="Multi-platform game development library"
+HOMEPAGE="https://github.com/sphair/ClanLib"
+SRC_URI="https://github.com/sphair/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="4.0"
+KEYWORDS="~amd64 ~x86" #not big endian safe #82779
+IUSE="cpu_flags_x86_sse2 doc examples ipv6 opengl sound static-libs X"
+REQUIRED_USE="opengl? ( X )"
+
+RDEPEND="
+ sys-libs/zlib
+ X? (
+ media-libs/freetype:2
+ media-libs/fontconfig
+ x11-libs/libX11
+ opengl? (
+ virtual/opengl
+ x11-libs/libXrender
+ )
+ )
+ sound? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-lang/perl
+ media-gfx/graphviz
+ )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-fix-build-system.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable opengl clanGL) \
+ $(use_enable opengl clanUI) \
+ $(use_enable X clanDisplay) \
+ $(use_enable sound clanSound) \
+ $(use_enable ipv6 getaddr) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake html
+}
+
+src_install() {
+ default
+
+ use doc && emake DESTDIR="${D}" install-html
+ use examples && dodoc -r Examples Resources
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch b/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch
new file mode 100644
index 000000000000..a3500e22f7e1
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch
@@ -0,0 +1,25 @@
+* Fix AM_CONDITIONAL to always be invoked
+* Install html files in proper --htmldir
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -437,8 +437,8 @@
+ fi
+
+ if test "$enable_clanSound" = "auto"; then enable_clanSound=yes; fi
+- AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+ fi
++AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ if test "$enable_clanNetwork" != "no"; then
+ echo "Checking for clanNetwork stuff"
+--- a/Documentation/Makefile.am
++++ b/Documentation/Makefile.am
+@@ -1,6 +1,6 @@
+ EXTRA_DIST = $(wildcart images/*.png)
+
+-HTML_PREFIX = $(datadir)/doc/@PACKAGE@-@LT_RELEASE@
++HTML_PREFIX = $(htmldir)
+
+ all-local:
+