summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/go-oauth2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/go-oauth2')
-rw-r--r--dev-go/go-oauth2/Manifest2
-rw-r--r--dev-go/go-oauth2/go-oauth2-0_pre20150527.ebuild58
-rw-r--r--dev-go/go-oauth2/go-oauth2-9999.ebuild25
-rw-r--r--dev-go/go-oauth2/metadata.xml10
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-go/go-oauth2/Manifest b/dev-go/go-oauth2/Manifest
new file mode 100644
index 000000000000..05ef330ea7e7
--- /dev/null
+++ b/dev-go/go-oauth2/Manifest
@@ -0,0 +1,2 @@
+DIST gcloud-golang-629ed086d82ad5d0ac3668e309b8785aaf54735b.tar.gz 144387 SHA256 bee11c31bc0f8914b4b72463033eb7432f28cec490673f4a12618b64868ee1f5 SHA512 33bdb3a9b3379bdd2502ade3ee9a41601effbd3f4bae88a7a7b4931866b73b336846b50994b254cac85571693566e12f4a23a0b8a0428d6aef1b301d468ef417 WHIRLPOOL 50426185042fe8b754b2db30b11fce588a189cb61e3e9781409edde6a5deb15a109ed1bf78e5831414762f497d3a6dcd98f2291f9c93b283059aa5b453ac9121
+DIST go-oauth2-0_pre20150527.tar.gz 32027 SHA256 eb1d48e29653b0bc68e41ef35df0d421e586e666ce52d7d504a6f2fb89807ce1 SHA512 9070bfed2e280286dbaeb360e77a9b2decf3e272e945ce4099875f7fd2e378b54082f8a9b4a2b7289d6984be4c66110d34b814cbc8e2850fd44122d484258fd4 WHIRLPOOL 09f19f1111f0a1d40ccff541c5cf4ad968264c91e9f6a3c18d23d441520002896b99f8f9979922dd4245edd9b46f89c46c94144b516c8424de43ccae8d462598
diff --git a/dev-go/go-oauth2/go-oauth2-0_pre20150527.ebuild b/dev-go/go-oauth2/go-oauth2-0_pre20150527.ebuild
new file mode 100644
index 000000000000..28f94fd16f11
--- /dev/null
+++ b/dev-go/go-oauth2/go-oauth2-0_pre20150527.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="Go client implementation for OAuth 2.0 spec"
+MY_PN=${PN##*-}
+GO_PN=golang.org/x/${MY_PN}
+HOMEPAGE="https://godoc.org/${GO_PN}"
+EGIT_COMMIT="b5adcc2dcdf009d0391547edc6ecbaff889f5bb9"
+SRC_URI="https://github.com/golang/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+https://github.com/GoogleCloudPlatform/gcloud-golang/archive/629ed086d82ad5d0ac3668e309b8785aaf54735b.tar.gz -> gcloud-golang-629ed086d82ad5d0ac3668e309b8785aaf54735b.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4
+ dev-go/go-net"
+RDEPEND=""
+S="${WORKDIR}/src/${GO_PN}"
+EGIT_CHECKOUT_DIR="${S}"
+STRIP_MASK="*.a"
+
+src_unpack() {
+ default
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${MY_PN}-${EGIT_COMMIT} src/${GO_PN} || die
+
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ export GOROOT="${WORKDIR}/goroot" GOPATH=${WORKDIR}
+ cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN}" || die
+
+ mkdir -p "${GOROOT}/src/google.golang.org" || die
+ rm -rf "${GOROOT}/src/google.golang.org"/* || die
+ rm -rf "${GOROOT}/pkg/${KERNEL}_${ARCH}/google.golang.org" || die
+ mv gcloud-golang-629ed086d82ad5d0ac3668e309b8785aaf54735b "${GOROOT}/src/google.golang.org/cloud" || die
+}
+
+src_compile() {
+ go install -v -x -work google.golang.org/cloud/compute/metadata || die
+ go install -v -x -work ${GO_PN}/... || die
+}
+
+src_test() {
+ # google/example_test.go imports appengine, introducing a circular dep
+ mv google/example_test.go{,_}
+ go test -x -v ${GO_PN}/... || die $?
+ mv google/example_test.go{_,}
+}
+
+src_install() {
+ insinto /usr/lib/go
+ find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ doins -r "${WORKDIR}"/{pkg,src}
+}
diff --git a/dev-go/go-oauth2/go-oauth2-9999.ebuild b/dev-go/go-oauth2/go-oauth2-9999.ebuild
new file mode 100644
index 000000000000..9fb295ad4390
--- /dev/null
+++ b/dev-go/go-oauth2/go-oauth2-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN=golang.org/x/oauth2
+EGO_SRC=golang.org/x/oauth2
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="b5adcc2dcdf009d0391547edc6ecbaff889f5bb9"
+ SRC_URI="https://github.com/golang/oauth2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go client implementation for OAuth 2.0 spec"
+HOMEPAGE="https://godoc.org/golang.org/x/oauth2"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND="dev-go/go-net:="
+RDEPEND=""
diff --git a/dev-go/go-oauth2/metadata.xml b/dev-go/go-oauth2/metadata.xml
new file mode 100644
index 000000000000..8d7ab33033c8
--- /dev/null
+++ b/dev-go/go-oauth2/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">GoogleCloudPlatform/gcloud-golang</remote-id>
+ </upstream>
+</pkgmetadata>