summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/go-resiliency
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/go-resiliency')
-rw-r--r--dev-go/go-resiliency/Manifest1
-rw-r--r--dev-go/go-resiliency/go-resiliency-1.0.0.ebuild58
-rw-r--r--dev-go/go-resiliency/go-resiliency-9999.ebuild25
-rw-r--r--dev-go/go-resiliency/metadata.xml10
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-go/go-resiliency/Manifest b/dev-go/go-resiliency/Manifest
new file mode 100644
index 000000000000..9ba0a1f4de36
--- /dev/null
+++ b/dev-go/go-resiliency/Manifest
@@ -0,0 +1 @@
+DIST go-resiliency-1.0.0.tar.gz 9504 SHA256 b4f5a9926e8b68f13e506001a9f52c1e3083a2ed171722ac857a4840d7c36486 SHA512 3847a9280543796fa3b5569d817e580f55819aa99e04a7737b235cb8ef578db018c51537f292e3f59ed10004cb0a7eabdf9870000fff25af4bf6d2af70510657 WHIRLPOOL 41404cb044e0a64608ffe58da2d77d8ed87606d58f408114e6e461e537cf5cb05460a95bee36a7d73e4be34cb6222c90eb97777d1cf13a40f88cc5101d21333d
diff --git a/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild b/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild
new file mode 100644
index 000000000000..3f06a6bdf2cd
--- /dev/null
+++ b/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/eapache/go-resiliency
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="Resiliency patterns for golang"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+}
diff --git a/dev-go/go-resiliency/go-resiliency-9999.ebuild b/dev-go/go-resiliency/go-resiliency-9999.ebuild
new file mode 100644
index 000000000000..ac53b2b8be62
--- /dev/null
+++ b/dev-go/go-resiliency/go-resiliency-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/eapache/go-resiliency
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Resiliency patterns for golang"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
diff --git a/dev-go/go-resiliency/metadata.xml b/dev-go/go-resiliency/metadata.xml
new file mode 100644
index 000000000000..009c68c39330
--- /dev/null
+++ b/dev-go/go-resiliency/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eapache/go-resiliency</remote-id>
+ </upstream>
+</pkgmetadata>