summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-08-23 14:47:06 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-08-23 14:47:06 +0200
commit21e7998249031c233aaedb2263f46dd08444e5fc (patch)
tree9d1d61882003f775b2c31374ed7230d6b8ca4a3a /dev-go
parentwww-client/firefox: Fix system-libevent support on x86, bug 621840 (diff)
downloadgentoo-21e7998249031c233aaedb2263f46dd08444e5fc.tar.gz
gentoo-21e7998249031c233aaedb2263f46dd08444e5fc.tar.bz2
gentoo-21e7998249031c233aaedb2263f46dd08444e5fc.zip
dev-go/gogo-protobuf: Initial version
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/gogo-protobuf/Manifest1
-rw-r--r--dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild41
-rw-r--r--dev-go/gogo-protobuf/metadata.xml13
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-go/gogo-protobuf/Manifest b/dev-go/gogo-protobuf/Manifest
new file mode 100644
index 000000000000..a7ad41ac5cf8
--- /dev/null
+++ b/dev-go/gogo-protobuf/Manifest
@@ -0,0 +1 @@
+DIST gogo-protobuf-0.4_p20170815.tar.gz 2572704 SHA256 f035a5be2c07ddbbfae821b372af68f70db504d1165c55b717dc4d5afcdf055f SHA512 3ab7f2e0006e537999e5fd0ba52272ad53c4707688401bb1e415007600f1ac5200dd8a03bd706977813b17c7712ba94a8b43fcf13b6498114a1d79c72bb216e7 WHIRLPOOL 7c7095989658bacd20c7038187344ea19c9111c8b2ba4601f0d06bd6ebc3309bbe0575073a0debb3d942a14c8ffc2986be5287a2413e8b1240560415b0b06a53
diff --git a/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild b/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild
new file mode 100644
index 000000000000..0abb1c6156a3
--- /dev/null
+++ b/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/gogo/protobuf"
+EGIT_COMMIT="fcdc5011193ff531a548e9b0301828d5a5b97fd8"
+
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Protocol Buffers for Go with Gadgets"
+HOMEPAGE="https://github.com/gogo/protobuf"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogo || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gofast || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogofast || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogoslick || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogofaster || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/protoc-gen-{gogo,gofast,gogofast,gogofaster}
+ dodoc src/${EGO_PN}/README
+}
diff --git a/dev-go/gogo-protobuf/metadata.xml b/dev-go/gogo-protobuf/metadata.xml
new file mode 100644
index 000000000000..d5168035cc6c
--- /dev/null
+++ b/dev-go/gogo-protobuf/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ </longdescription>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gogo/protobuf</remote-id>
+ </upstream>
+</pkgmetadata>