summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/ascii-progress
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/ascii-progress')
-rw-r--r--dev-haskell/ascii-progress/Manifest1
-rw-r--r--dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild40
-rw-r--r--dev-haskell/ascii-progress/metadata.xml15
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/ascii-progress/Manifest b/dev-haskell/ascii-progress/Manifest
new file mode 100644
index 000000000000..2951f7098818
--- /dev/null
+++ b/dev-haskell/ascii-progress/Manifest
@@ -0,0 +1 @@
+DIST ascii-progress-0.2.1.2.tar.gz 6385 SHA256 3c384b6401243bbe5acb735f1550b59622cf5b2fa8ef4cb8b870c2f609bcdd52 SHA512 cc1a9f1d48d522fe3a8d9afe7a200c2bd4f9e573f99ccae0993af75ab15ede8bfe7630776385e680af3540661613c60cf7aa81a08b9b83b5d8f72aaf8f869b52 WHIRLPOOL 55cb970706e926fb1625a6d1af1d327798596d3a1dbee69ceb8b7fca65f28bda5c2d8ec4ca963c63d2a3c67b81aa1d852a864f6bb51739eab2c66b2d1095fe2f
diff --git a/dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild b/dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild
new file mode 100644
index 000000000000..344ca3986f64
--- /dev/null
+++ b/dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A simple progress bar for the console"
+HOMEPAGE="https://github.com/yamadapc/haskell-ascii-progress"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-haskell/ansi-terminal:=[profile?]
+ >=dev-haskell/async-2.0.1.5:=[profile?]
+ >=dev-haskell/conduit-1.2:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?]
+ dev-haskell/http:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-2.1 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2.6 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples)
+}
diff --git a/dev-haskell/ascii-progress/metadata.xml b/dev-haskell/ascii-progress/metadata.xml
new file mode 100644
index 000000000000..d938f439fb5f
--- /dev/null
+++ b/dev-haskell/ascii-progress/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A simple Haskell progress bar for the console. Heavily borrows from TJ
+ Holowaychuk's Node.JS project
+ &lt;https://github.com/tj/node-progress progress&gt;
+
+ &lt;https://github.com/yamadapc/haskell-ascii-progress github&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">yamadapc/haskell-ascii-progress</remote-id>
+ </upstream>
+</pkgmetadata>