summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-18 11:08:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-18 11:28:27 +0000
commit244f2233cdbc6197709c0d174c45abd0fb52ae5c (patch)
treefff611fa531631f348c97a812d9e371c57a8859a /dev-haskell
parentdev-haskell/weigh: new package, a depend of pandoc-1.19 (diff)
downloadgentoo-244f2233cdbc6197709c0d174c45abd0fb52ae5c.tar.gz
gentoo-244f2233cdbc6197709c0d174c45abd0fb52ae5c.tar.bz2
gentoo-244f2233cdbc6197709c0d174c45abd0fb52ae5c.zip
dev-haskell/skylighting: new package, a depend of pandoc-1.19
syntax highlighting library Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/skylighting/Manifest1
-rw-r--r--dev-haskell/skylighting/metadata.xml21
-rw-r--r--dev-haskell/skylighting/skylighting-0.1.1.5.ebuild49
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/skylighting/Manifest b/dev-haskell/skylighting/Manifest
new file mode 100644
index 000000000000..4792e9069867
--- /dev/null
+++ b/dev-haskell/skylighting/Manifest
@@ -0,0 +1 @@
+DIST skylighting-0.1.1.5.tar.gz 584235 SHA256 0a4b666b2ccfeed35386bd364d663e919adc1815547e6360e83487253e33b13c SHA512 2d430d2067d7694978620af0c63ce47240074055bf5179b968ac2a430b9968f445307347c8975e550823f509c05ab600f07c3d1cdc7f8909bf19506e0153e3ef WHIRLPOOL 485e205f0d5a76727e455ab718dc9666ae3552bcc994fd68e708fb13e12779e597890a5282bb4753aae0b15bb8186e33566b23d7f4b25aefed70edcb664372af
diff --git a/dev-haskell/skylighting/metadata.xml b/dev-haskell/skylighting/metadata.xml
new file mode 100644
index 000000000000..b5e26be25d24
--- /dev/null
+++ b/dev-haskell/skylighting/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="executable">Build the skylighting executable.</flag>
+ </use>
+ <longdescription>
+ Skylighting is a syntax highlighting library with
+ support for over one hundred languages. It derives
+ its tokenizers from XML syntax definitions used
+ by KDE&#39;s KSyntaxHighlighting framework, so any
+ syntax supported by that framework can be added.
+ An optional command-line program is provided.
+ Skylighting is intended to be the successor to
+ highlighting-kate.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild b/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild
new file mode 100644
index 000000000000..cfc65da0be6e
--- /dev/null
+++ b/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -bootstrap
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/hxt:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/regex-pcre-builtin:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ executable? ( dev-haskell/pretty-show:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/diff
+ dev-haskell/hunit
+ dev-haskell/random
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ !executable? ( dev-haskell/pretty-show ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap \
+ $(cabal_flag executable executable)
+}