summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-10-22 22:23:41 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2015-10-22 22:31:46 +0100
commit4814995991699fb33dd852e6009940d1b61e4534 (patch)
treed9ff7bebcd81b0f2cd4ff93d52963be5a55856b1 /dev-haskell
parentdev-haskell/ghc-syb-utils: new package (diff)
downloadgentoo-4814995991699fb33dd852e6009940d1b61e4534.tar.gz
gentoo-4814995991699fb33dd852e6009940d1b61e4534.tar.bz2
gentoo-4814995991699fb33dd852e6009940d1b61e4534.zip
dev-haskell/fclabels: new package
"First class accessor labels implemented as lenses", a depend of app-emacs/ghc-mod Bug: https://bugs.gentoo.org/show_bug.cgi?id=476352 Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/fclabels/Manifest1
-rw-r--r--dev-haskell/fclabels/fclabels-2.0.2.3.ebuild28
-rw-r--r--dev-haskell/fclabels/metadata.xml26
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/fclabels/Manifest b/dev-haskell/fclabels/Manifest
new file mode 100644
index 000000000000..4f33a57bdca4
--- /dev/null
+++ b/dev-haskell/fclabels/Manifest
@@ -0,0 +1 @@
+DIST fclabels-2.0.2.3.tar.gz 22787 SHA256 82ba7747afeec6526d3bc2df61b222ae71b45aa3dd8bb8787e9ab2c537f6fad5 SHA512 54e6391ec9fa3c3032c9609a1df0f2082947342a6ea48f3378686eec5bf14bc29ca2f7243ab74fa69b2b18a0749ab40417f59e7338cb5fdc1c4404fb00b6dd7d WHIRLPOOL 178b94abd8a66484253eb10fba2cbf15e0443a58db02ea9c708e77c7fa18ff48cb7f5b6e8e563a2517fe1c9968a05f115a5f10f42e728e1f43054f26370d3d73
diff --git a/dev-haskell/fclabels/fclabels-2.0.2.3.ebuild b/dev-haskell/fclabels/fclabels-2.0.2.3.ebuild
new file mode 100644
index 000000000000..0249b5553fbb
--- /dev/null
+++ b/dev-haskell/fclabels/fclabels-2.0.2.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="First class accessor labels implemented as lenses"
+HOMEPAGE="https://github.com/sebastiaanvisser/fclabels"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-1.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.4 )
+"
diff --git a/dev-haskell/fclabels/metadata.xml b/dev-haskell/fclabels/metadata.xml
new file mode 100644
index 000000000000..1ad043312608
--- /dev/null
+++ b/dev-haskell/fclabels/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package provides first class labels that can act as
+ bidirectional record fields. The labels can be derived
+ automatically using Template Haskell which means you don&#39;t have
+ to write any boilerplate yourself. The labels are implemented as
+ lenses and are fully composable. Labels can be used to /get/,
+ /set/ and /modify/ parts of a datatype in a consistent way.
+
+ See &quot;Data.Label&quot; for an introductory explanation.
+
+ Internally lenses are not tied to Haskell functions directly,
+ but are implemented as arrows. Arrows allow the lenses to be run
+ in custom computational contexts. This approach allows us to
+ make partial lenses that point to fields of multi-constructor
+ datatypes in an elegant way.
+
+ See the &quot;Data.Label.Maybe&quot; module for the use of partial labels.
+
+ &gt; 1.0.3 -&gt; 1.0.4
+ &gt; - Bugfix to compile on GHC 6.12 again.
+ </longdescription>
+</pkgmetadata>