summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-09-21 20:51:23 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2015-09-21 20:52:02 +0100
commita02ea22bcca692fa252bbf4d15d4ffb456321a47 (patch)
treedbd79f34a5c33fe44ee518cf61eb9aee3fd1d11b /dev-haskell
parentmedia-libs/mesa: Update to use upstream glx-read-only-text flag. (diff)
downloadgentoo-a02ea22bcca692fa252bbf4d15d4ffb456321a47.tar.gz
gentoo-a02ea22bcca692fa252bbf4d15d4ffb456321a47.tar.bz2
gentoo-a02ea22bcca692fa252bbf4d15d4ffb456321a47.zip
dev-haskell/shellish: tweak for ghc-7.10, bug #561028
Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/561028 Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch9
-rw-r--r--dev-haskell/shellish/shellish-0.1.4.ebuild6
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch b/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch
new file mode 100644
index 000000000000..c756635f6000
--- /dev/null
+++ b/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch
@@ -0,0 +1,9 @@
+diff --git a/Shellish.hs b/Shellish.hs
+index 1e3c192..0ac20c2 100644
+--- a/Shellish.hs
++++ b/Shellish.hs
+@@ -1,3 +1,3 @@
+ {-# LANGUAGE ScopedTypeVariables, DeriveDataTypeable, OverloadedStrings,
+- MultiParamTypeClasses, FlexibleInstances #-}
++ MultiParamTypeClasses, FlexibleInstances, FlexibleContexts #-}
+
diff --git a/dev-haskell/shellish/shellish-0.1.4.ebuild b/dev-haskell/shellish/shellish-0.1.4.ebuild
index 86f421a07c2b..f93d8797cc7a 100644
--- a/dev-haskell/shellish/shellish-0.1.4.ebuild
+++ b/dev-haskell/shellish/shellish-0.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -24,3 +24,7 @@ RDEPEND="dev-haskell/mtl[profile?]
>=dev-lang/ghc-6.10.1"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}