summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/ant-ivy/ant-ivy-2.0.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/ant-ivy/ant-ivy-2.0.0.ebuild')
-rw-r--r--dev-java/ant-ivy/ant-ivy-2.0.0.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/dev-java/ant-ivy/ant-ivy-2.0.0.ebuild b/dev-java/ant-ivy/ant-ivy-2.0.0.ebuild
new file mode 100644
index 000000000000..9b482b8a76a7
--- /dev/null
+++ b/dev-java/ant-ivy/ant-ivy-2.0.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+JAVA_PKG_IUSE="doc examples source test"
+# registers as split-ant task
+WANT_SPLIT_ANT="true"
+# rewrites examples otherwise... bad
+JAVA_PKG_BSFIX_ALL="no"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_PN="apache-ivy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Ivy is a free java based dependency manager"
+HOMEPAGE="http://ant.apache.org/ivy"
+SRC_URI="mirror://apache/ant/ivy/${PV}/${MY_P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+RESTRICT="test" # We cannot build tests yet as there is no org.apache.tools.ant.BuildFileTest packaged anywhere yet
+
+# There may be additional optional dependencies (commons-logging, commons-lang...)
+
+COMMON_DEP="
+ dev-java/ant-core:0
+ dev-java/jakarta-oro:2.0
+ dev-java/jsch:0
+ dev-java/commons-httpclient:3
+ dev-java/commons-vfs:0"
+
+DEPEND="
+ >=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )
+ ${COMMON_DEP}"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm -rf test/repositories
+ rm -rf test/triggers
+ rm -rf src/example/chained-resolvers/settings/repository/test-1.0.jar
+ rm -rf test/java/org/apache/ivy/core/settings/custom-resolver.jar
+
+ # Removing obsolete documentation
+
+ rm -rf doc/reports
+ rm -rf doc/configuration
+
+ java-ant_rewrite-classpath
+ mkdir lib
+}
+
+EANT_GENTOO_CLASSPATH="ant-core,commons-vfs,jakarta-oro-2.0,jsch
+ commons-httpclient-3"
+
+EANT_BUILD_TARGET="/offline jar"
+
+EANT_EXTRA_ARGS="-Dbuild.version=${PV} -Dbundle.version=${PV}"
+
+src_test() {
+ java-pkg_jar-from --into lib junit
+ ANT_TASKS="ant-junit" eant "/offline test"
+}
+
+src_install() {
+ java-pkg_dojar "build/artifact/jars/ivy.jar"
+
+ use doc && java-pkg_dojavadoc "build/doc/reports/api"
+ use doc && dohtml -r "doc"
+ use examples && java-pkg_doexamples "src/example"
+ use source && java-pkg_dosrc src/java/*
+
+ java-pkg_register-ant-task
+}