summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-beanutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-beanutils')
-rw-r--r--dev-java/commons-beanutils/Manifest2
-rw-r--r--dev-java/commons-beanutils/commons-beanutils-1.8.0.ebuild66
-rw-r--r--dev-java/commons-beanutils/commons-beanutils-1.8.3.ebuild63
-rw-r--r--dev-java/commons-beanutils/metadata.xml5
4 files changed, 136 insertions, 0 deletions
diff --git a/dev-java/commons-beanutils/Manifest b/dev-java/commons-beanutils/Manifest
new file mode 100644
index 000000000000..75c0960b3415
--- /dev/null
+++ b/dev-java/commons-beanutils/Manifest
@@ -0,0 +1,2 @@
+DIST commons-beanutils-1.8.0-src.tar.gz 379586 SHA256 aff3c8c772e4ff32f2d9a37a727a488583372e45535a3d5aad09662691851dcf SHA512 2a3ea0ff09b24517defcd9f15552b1820e87296b9d6f920732a81c3ab10ad927e247d787ba8bd60100dfd6e2222a15d6ee6933217ff57263eaa07ec6ea0f078a WHIRLPOOL 88861f583317325275c72d10aebe104906d117ce4ce0d6cd079cacb2c3bde92a6b8419b87e317e5239cc0351fe3d29942b9e0d8afdb00e4bc86a377b6a35399a
+DIST commons-beanutils-1.8.3-src.tar.gz 383126 SHA256 df6d6a625db8da38b33d018030715130a258c0b493ea39f20c5e8d075b21b4ed SHA512 5cbe2774f097920db3b9dae99e7e6aa3c772826592c6f3b9db1ab9e3cc60631db60f0f9207c2f5335054288830085a6f0bf1da848300144c2a066b3a40e121b3 WHIRLPOOL 5ccf2ffab347db9d7276f64e7a293c1836699024c1fdb7321ec06f2cfd43d22a6e10938bb7637912ff22fe17417a534ac55266a16b81ef5fe85b9dfd0184fcab
diff --git a/dev-java/commons-beanutils/commons-beanutils-1.8.0.ebuild b/dev-java/commons-beanutils/commons-beanutils-1.8.0.ebuild
new file mode 100644
index 000000000000..e8de4ae2663c
--- /dev/null
+++ b/dev-java/commons-beanutils/commons-beanutils-1.8.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Provides easy-to-use wrappers around Reflection and Introspection APIs"
+HOMEPAGE="http://commons.apache.org/beanutils/"
+SRC_URI="mirror://apache/commons/beanutils/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.7"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+COMMON_DEP="
+ >=dev-java/commons-collections-2.1:0
+ >=dev-java/commons-logging-1.0.2:0"
+RDEPEND=">=virtual/jre-1.4
+ !<=dev-java/commons-betwixt-0.7-r1:0.7
+ !dev-java/commons-beanutils-collections
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ test? (
+ dev-java/ant-junit
+ dev-java/junit:0
+ dev-java/commons-collections[test-framework]
+ )
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ rm -vr src/java/org/apache/commons/collections/ || die
+ # from pom.xml:
+ # <!-- This test case is known to fail, and there isn't any proposed fix
+ # - so we will just exclude it until someone comes up with a solution.
+ # -->
+ rm -v ./src/test/org/apache/commons/beanutils/memoryleaktests/MemoryLeakTestCase.java || die
+ JAVA_ANT_CLASSPATH_TAGS="javac java" java-ant_rewrite-classpath
+}
+
+EANT_GENTOO_CLASSPATH="commons-logging,commons-collections"
+
+src_test() {
+ EANT_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit"
+ ANT_TASKS="ant-junit" eant \
+ -Dcommons-collections.jar=$(java-pkg_getjar commons-collections commons-collections.jar) \
+ -Dcommons-collections-testframework.jar=$(java-pkg_getjar commons-collections commons-collections-testframework.jar) \
+ -Dcommons-logging.jar=$(java-pkg_getjar commons-logging commons-logging.jar) \
+ test
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar
+ java-pkg_newjar dist/${PN}-core-${PV}.jar ${PN}-core.jar
+ java-pkg_newjar dist/${PN}-bean-collections-${PV}.jar ${PN}-bean-collections.jar
+
+ dodoc README.txt RELEASE-NOTES.txt || die
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/org
+}
diff --git a/dev-java/commons-beanutils/commons-beanutils-1.8.3.ebuild b/dev-java/commons-beanutils/commons-beanutils-1.8.3.ebuild
new file mode 100644
index 000000000000..e4546344a36c
--- /dev/null
+++ b/dev-java/commons-beanutils/commons-beanutils-1.8.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Provides easy-to-use wrappers around Reflection and Introspection APIs"
+HOMEPAGE="http://commons.apache.org/beanutils/"
+SRC_URI="mirror://apache/commons/beanutils/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.7"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/commons-collections:0
+ dev-java/commons-logging:0"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ test? (
+ dev-java/ant-junit
+ dev-java/junit:0
+ dev-java/commons-collections[test-framework]
+ )
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ rm -vr src/main/java/org/apache/commons/collections/ || die
+ # from pom.xml:
+ # <!-- This test case is known to fail, and there isn't any proposed fix
+ # - so we will just exclude it until someone comes up with a solution.
+ # -->
+ JAVA_ANT_CLASSPATH_TAGS="javac java" java-ant_rewrite-classpath
+}
+
+EANT_GENTOO_CLASSPATH="commons-logging,commons-collections"
+
+src_test() {
+ EANT_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit"
+ ANT_TASKS="ant-junit" eant \
+ -Dcommons-collections.jar=$(java-pkg_getjar commons-collections commons-collections.jar) \
+ -Dcommons-collections-testframework.jar=$(java-pkg_getjar commons-collections commons-collections-testframework.jar) \
+ -Dcommons-logging.jar=$(java-pkg_getjar commons-logging commons-logging.jar) \
+ test
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar
+ java-pkg_newjar dist/${PN}-core-${PV}.jar ${PN}-core.jar
+ java-pkg_newjar dist/${PN}-bean-collections-${PV}.jar ${PN}-bean-collections.jar
+
+ dodoc README.txt RELEASE-NOTES.txt || die
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/commons-beanutils/metadata.xml b/dev-java/commons-beanutils/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-beanutils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>