summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-08-10 22:43:36 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-08-10 22:44:14 +0100
commit84b61226dcea2f9d28f4cce3fd8356c89472de07 (patch)
tree29e38340dd91a00574d06e0542cde22a9f44fbee /dev-java/hawtjni-runtime
parentdev-java/maven-hawtjni-plugin: Drop old 1.11 (diff)
downloadgentoo-84b61226dcea2f9d28f4cce3fd8356c89472de07.tar.gz
gentoo-84b61226dcea2f9d28f4cce3fd8356c89472de07.tar.bz2
gentoo-84b61226dcea2f9d28f4cce3fd8356c89472de07.zip
dev-java/hawtjni-runtime: Version bump to 1.15, EAPI 6
Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'dev-java/hawtjni-runtime')
-rw-r--r--dev-java/hawtjni-runtime/Manifest1
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.15.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-java/hawtjni-runtime/Manifest b/dev-java/hawtjni-runtime/Manifest
index 72692181c98a..047926fe1f65 100644
--- a/dev-java/hawtjni-runtime/Manifest
+++ b/dev-java/hawtjni-runtime/Manifest
@@ -1 +1,2 @@
DIST hawtjni-project-1.10.tar.gz 1602839 BLAKE2B 7a6a37c4c208906fc7718bbd1aec566bb2392ef0e0dc082aa552127e97af896ad39b2ecfcd124ac370593daecd69185c184838fafc374173320beee72d87fccb SHA512 3bd94d20bf2d8953c60753aa404077c96c93704c2bd5bebfb5fe790fc29e15d97f6172706f06cea13c4806b652405ccfef824cccf76ff018dafb7262ff845490
+DIST hawtjni-project-1.15.tar.gz 1606236 BLAKE2B 52357dbefde43ec82cf218ada90642d118ebaa6a6be173cc1f4f48377fda95b902f0a90dfb60822c02c144b9bf13d0800c94d67cc2f9c76e607bbbb80a80898e SHA512 1a93658bf8621c770cf97b546c6a5c0cf1821b06cb16dbc872ad0c830c599d3947ffe56b4cca16217a510d4e929ebcfc5eabdf4ad4364f5225b53d22c7d48abb
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.15.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.15.ebuild
new file mode 100644
index 000000000000..bcbf6c1590cc
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="hawtjni-project-${PV}"
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}/hawtjni-${MY_P}/${PN}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../../{changelog,notice,readme}.md
+}