summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-18 14:27:50 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-18 19:37:05 +0000
commit8f5d2ee18eaa720ba4ddd6dfed7f6e2b1188991f (patch)
treec82105fcb0882af54cdeaa2dca8f23858c37cc65 /dev-java/jopt-simple/jopt-simple-4.8.ebuild
parentdev-java/httpcomponents-core: Add missing dies. (diff)
downloadgentoo-8f5d2ee18eaa720ba4ddd6dfed7f6e2b1188991f.tar.gz
gentoo-8f5d2ee18eaa720ba4ddd6dfed7f6e2b1188991f.tar.bz2
gentoo-8f5d2ee18eaa720ba4ddd6dfed7f6e2b1188991f.zip
dev-java/jopt-simple: Version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/jopt-simple/jopt-simple-4.8.ebuild')
-rw-r--r--dev-java/jopt-simple/jopt-simple-4.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/jopt-simple/jopt-simple-4.8.ebuild b/dev-java/jopt-simple/jopt-simple-4.8.ebuild
new file mode 100644
index 000000000000..bffe67c8fdb8
--- /dev/null
+++ b/dev-java/jopt-simple/jopt-simple-4.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java library for parsing command line options"
+HOMEPAGE="https://pholser.github.com/jopt-simple/"
+SRC_URI="https://github.com/pholser/${PN}/tarball/${P} -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+S="${WORKDIR}/pholser-${PN}-587d4ee"
+
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ # Easier to use java-pkg-simple.
+ rm -v pom.xml || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc README.md
+}