summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/nanoxml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/nanoxml')
-rw-r--r--dev-java/nanoxml/Manifest1
-rw-r--r--dev-java/nanoxml/metadata.xml5
-rw-r--r--dev-java/nanoxml/nanoxml-2.2.3-r2.ebuild57
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-java/nanoxml/Manifest b/dev-java/nanoxml/Manifest
new file mode 100644
index 000000000000..60f31ee38b7d
--- /dev/null
+++ b/dev-java/nanoxml/Manifest
@@ -0,0 +1 @@
+DIST NanoXML-2.2.3.tar.gz 426111 SHA256 df3bd3663b766851caffba963853383cff813695dca3e827ce6e00a920d544fa SHA512 6800b86039cb555efc05644db65c516fb242d4d081ea612969d6cc52a12ffd7571e012a7afe7962cd61c28b0ebb3b9d94af76f20013f3b4dd7d2aacdc552c6fc WHIRLPOOL 3164e5c09b2e42058da1c2c3df55512dfc75245dca7857fb46085f1a6b0a8a4360397026825a6e0f3ce66fab9c55774ad65ee9d6daf072ee9f0bae42d6509882
diff --git a/dev-java/nanoxml/metadata.xml b/dev-java/nanoxml/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/nanoxml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/nanoxml/nanoxml-2.2.3-r2.ebuild b/dev-java/nanoxml/nanoxml-2.2.3-r2.ebuild
new file mode 100644
index 000000000000..2f5f1882abd1
--- /dev/null
+++ b/dev-java/nanoxml/nanoxml-2.2.3-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="NanoXML is a small non-validating parser for Java. "
+
+HOMEPAGE="http://nanoxml.sourceforge.net/"
+MY_P=NanoXML-${PV}
+SRC_URI="http://nanoxml.cyberelf.be/downloads/${MY_P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+COMMON_DEP="dev-java/sax"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/ThirdParty/SAX
+ java-pkg_jar-from sax
+ cd ${S}
+
+ local docsed
+ if use doc; then
+ docsed="javadoc -source $(java-pkg_get-source)"
+ else
+ docsed="true"
+ fi
+
+ # Use the right arguments for javac/javadoc
+ sed -e "s:/tmp/:${T}/:g" \
+ -e "s/javac/javac $(java-pkg_javac-args)/" \
+ -e "s/-target 1.1//" \
+ -e "s/javadoc/${docsed}/" \
+ -i build.sh || die "failed to sed"
+}
+
+src_compile() {
+ ./build.sh || die "failed to build"
+}
+
+src_install() {
+ java-pkg_dojar Output/*.jar
+
+ dohtml -r Documentation/NanoXML-*
+ use doc && java-pkg_dojavadoc Documentation/JavaDoc
+}