summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/osgi-core-api
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/osgi-core-api')
-rw-r--r--dev-java/osgi-core-api/Manifest2
-rw-r--r--dev-java/osgi-core-api/metadata.xml6
-rw-r--r--dev-java/osgi-core-api/osgi-core-api-4.3.ebuild30
-rw-r--r--dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild30
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-java/osgi-core-api/Manifest b/dev-java/osgi-core-api/Manifest
new file mode 100644
index 000000000000..d5c0c843e5a7
--- /dev/null
+++ b/dev-java/osgi-core-api/Manifest
@@ -0,0 +1,2 @@
+DIST osgi-core-api-4.3-all.zip 337463 SHA256 e03188926e6dfbc87ef7a097226c6cd01e399747d75e03a233961de661b13fbc SHA512 4620e96e0a24661a0d3f3a570598d51ba9068b7204f3dd34179bdca76ad9f2edf2e20c1656f0dc355be647a2b5befc064ff50b8f75167639580fb5ef661292c1 WHIRLPOOL 97634762b8c2042301d78312baff5bc575314d5ded28d673d69f354c1e5b23d3845bd4d90421f6d2fe20574386ae5d88e126da90d1fde8aabe71530cc2b8f65f
+DIST osgi.core-5.0.0.jar 418232 SHA256 22fe6c64753a0479fb450bcb740ea5e51747cca2e1aabb8a582d50c02c3eec94 SHA512 de7c5aa327a4361b81d953951488b84071e525cfd3e50f0334450b8c1b25733248de9459239ee7091f8961ac8b047a0492d692fb7cd408a0ec07df090ea9e2c3 WHIRLPOOL 9164e08ccd6f079898d0dedd33df1ea1f76f3ed4e65fe9205d17e72e6d8f6e5820fbab7a0bbe9633efa85f9ff4a9045813ea9d193dc110f5b6bd7d67a98b621c
diff --git a/dev-java/osgi-core-api/metadata.xml b/dev-java/osgi-core-api/metadata.xml
new file mode 100644
index 000000000000..95a67909c7b5
--- /dev/null
+++ b/dev-java/osgi-core-api/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
+
diff --git a/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild b/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild
new file mode 100644
index 000000000000..40fa4291c0af
--- /dev/null
+++ b/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
+HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
+SRC_URI="http://www.osgi.org/download/r4v${PV//./}/osgi.core-${PV}.0.jar -> ${P}-all.zip"
+
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+java_prepare() {
+ rm -r org || die
+}
diff --git a/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild b/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild
new file mode 100644
index 000000000000..f0528eaa5133
--- /dev/null
+++ b/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
+HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
+SRC_URI="http://www.osgi.org/download/r5/osgi.core-${PV}.jar"
+
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+java_prepare() {
+ rm -r org || die
+}