summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-04 09:00:56 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-04 09:49:46 +0000
commit3d26143ba4690371286ed2059adbbc9398dc46e1 (patch)
treec61d9f794da957aab85b340def38bca956d4ee95 /dev-java/sablecc
parentpackage.mask: Adjusted mask on x11-misc/lightdm (diff)
downloadgentoo-3d26143ba4690371286ed2059adbbc9398dc46e1.tar.gz
gentoo-3d26143ba4690371286ed2059adbbc9398dc46e1.tar.bz2
gentoo-3d26143ba4690371286ed2059adbbc9398dc46e1.zip
dev-java/sablecc: Convert to java-pkg-simple.
--straight-to-stable because the current stable version is broken. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/sablecc')
-rw-r--r--dev-java/sablecc/sablecc-3.7-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/sablecc/sablecc-3.7-r1.ebuild b/dev-java/sablecc/sablecc-3.7-r1.ebuild
new file mode 100644
index 000000000000..4892847e4245
--- /dev/null
+++ b/dev-java/sablecc/sablecc-3.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java based compiler / parser generator"
+HOMEPAGE="http://www.sablecc.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher "${PN}" --main org.sablecc.sablecc.SableCC
+ dodoc AUTHORS THANKS
+ dohtml README.html
+}