summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/spymemcached
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/spymemcached')
-rw-r--r--dev-java/spymemcached/Manifest1
-rw-r--r--dev-java/spymemcached/metadata.xml12
-rw-r--r--dev-java/spymemcached/spymemcached-2.9.1.ebuild41
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/spymemcached/Manifest b/dev-java/spymemcached/Manifest
new file mode 100644
index 000000000000..d1a77248648f
--- /dev/null
+++ b/dev-java/spymemcached/Manifest
@@ -0,0 +1 @@
+DIST spymemcached-2.9.1-sources.jar 305723 SHA256 ae4e650e112da383f1cd27b63cc9ec2c3a50dcdc4d61a35ca975ae90ce778ea0 SHA512 3d7b593a095094e4b564eef8112f8f9ad0e812f313b5a943e669115c1aa4662795e9321a75e030ab7bb954a810ffb92c399041ed4b29e8f703aecf80d7603614 WHIRLPOOL cf431f3cd2a8e6d4e0f9c3301071827a883310be8d33ca050ff94c2b16264d79b1df6e95e492e0e38cfa1f7e2b5dd2109c616bcde2a30815c3bb116ba893826f
diff --git a/dev-java/spymemcached/metadata.xml b/dev-java/spymemcached/metadata.xml
new file mode 100644
index 000000000000..9cb4302d604b
--- /dev/null
+++ b/dev-java/spymemcached/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <use>
+ <flag name='spring'>Build support for the spring framework</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">spymemcached</remote-id>
+ </upstream>
+</pkgmetadata>
+
diff --git a/dev-java/spymemcached/spymemcached-2.9.1.ebuild b/dev-java/spymemcached/spymemcached-2.9.1.ebuild
new file mode 100644
index 000000000000..5a9328d3a369
--- /dev/null
+++ b/dev-java/spymemcached/spymemcached-2.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A simple, asynchronous, single-threaded memcached client written in java"
+HOMEPAGE="https://code.google.com/p/spymemcached/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}-sources.jar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="spring"
+
+CDEPEND="dev-java/log4j:0
+ dev-java/slf4j-api:0
+ spring? ( dev-java/spring-beans:3.2 )"
+
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+S="${WORKDIR}"
+
+JAVA_GENTOO_CLASSPATH="log4j,slf4j-api"
+
+java_prepare() {
+ if use spring; then
+ JAVA_GENTOO_CLASSPATH+=",spring-beans-3.2"
+ else
+ rm net/spy/memcached/spring/MemcachedClientFactoryBean.java || die
+ fi
+}