summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/stax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/stax')
-rw-r--r--dev-java/stax/Manifest1
-rw-r--r--dev-java/stax/files/1.2.0-build-version.patch11
-rw-r--r--dev-java/stax/metadata.xml11
-rw-r--r--dev-java/stax/stax-1.2.0.ebuild54
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-java/stax/Manifest b/dev-java/stax/Manifest
new file mode 100644
index 000000000000..ce74d6267940
--- /dev/null
+++ b/dev-java/stax/Manifest
@@ -0,0 +1 @@
+DIST stax-src-1.2.0.zip 310738 SHA256 c4dc2ef0be6a21dcdb5643ab89e9cb3b62f18ad213967a9ba3901b71cd97843a SHA512 41686d961c7a211ee02e9432a141ff75326414da9576608a3567ca7e154ed24ad804cd01849364a5ec8def1a6e5048197850bafd67fc5ff2b6a10307a0fec9af WHIRLPOOL 8f9aea0015acb10eaefa184700701a624ed1f45d8e7b236661663da2e3a0a8b2fb129653d08edc19344b573e537c5fb44123a6791c0141bd073aad1b8fb9a621
diff --git a/dev-java/stax/files/1.2.0-build-version.patch b/dev-java/stax/files/1.2.0-build-version.patch
new file mode 100644
index 000000000000..4880d1f00776
--- /dev/null
+++ b/dev-java/stax/files/1.2.0-build-version.patch
@@ -0,0 +1,11 @@
+--- stax/build.xml 2006-06-16 18:17:56.000000000 +0200
++++ build.xml 2007-02-24 19:21:46.875023427 +0100
+@@ -23,7 +23,7 @@
+ />
+
+ <!-- API properties -->
+- <property name="api_version" value="1.0.1"/>
++ <property name="api_version" value="1.2.0"/>
+ <property name="api_src_dir" value="${build_dir}/api_src"/>
+ <property name="api_dir" value="api"/>
+ <property name="jar_api" value="${build_dir}/stax-api-${api_version}.jar"/>
diff --git a/dev-java/stax/metadata.xml b/dev-java/stax/metadata.xml
new file mode 100644
index 000000000000..370119aceffe
--- /dev/null
+++ b/dev-java/stax/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+Features of StAX API: Standard pull parser interface,
+Read/Write API: two levels, "raw" cursor access; object-based "event" access,
+Efficient XML access (especiall cursor API), Gives application control over
+parsing: "reverse Hollywood": you can call us, instead of waiting us to call you.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-java/stax/stax-1.2.0.ebuild b/dev-java/stax/stax-1.2.0.ebuild
new file mode 100644
index 000000000000..4d9033619442
--- /dev/null
+++ b/dev-java/stax/stax-1.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A standard XML processing API that allows you to stream XML data from and to your application"
+HOMEPAGE="http://stax.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${PN}-src-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+
+# test? ( dev-java/ant-junit dev-java/ant-trax dev-java/xerces )
+DEPEND="
+ >=virtual/jdk-1.4
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}" || die "cd failed"
+ epatch "${FILESDIR}/1.2.0-build-version.patch"
+}
+
+EANT_BUILD_TARGET="ri_bin_dist"
+
+# A lot of these fail and that seems expected based on upstream
+# svn logs
+RESTRICT="test"
+
+src_test() {
+ mkdir lib
+ java-ant_rewrite-classpath build.xml
+ ANT_TASKS="ant-junit ant-trax" \
+ EANT_GENTOO_CLASSPATH="junit,xerces-2" eant test
+}
+
+src_install() {
+ java-pkg_newjar ${S}/build/stax-api-${PV}.jar stax-api.jar
+ java-pkg_newjar ${S}/build/stax-${PV}-dev.jar stax-dev.jar
+
+ if use doc; then
+ java-pkg_dojavadoc "${S}/build/javadoc"
+ fi
+ use source && java-pkg_dosrc src/*
+}