summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-06-03 14:55:41 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-03 21:12:22 -0400
commit7420020022fcb9aa8d223798b489a4d518dbac08 (patch)
treebcd2d2ad48e91063dbe60f9fc117113b5b174273 /dev-java
parentdev-java/ant-ivy: drop old EAPI (diff)
downloadgentoo-7420020022fcb9aa8d223798b489a4d518dbac08.tar.gz
gentoo-7420020022fcb9aa8d223798b489a4d518dbac08.tar.bz2
gentoo-7420020022fcb9aa8d223798b489a4d518dbac08.zip
dev-java/jgoodies-binding: drop old EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jgoodies-binding/Manifest1
-rw-r--r--dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r1.ebuild43
-rw-r--r--dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild60
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-java/jgoodies-binding/Manifest b/dev-java/jgoodies-binding/Manifest
index cc1299f17ac3..b4b653a2e7de 100644
--- a/dev-java/jgoodies-binding/Manifest
+++ b/dev-java/jgoodies-binding/Manifest
@@ -1,2 +1 @@
-DIST binding-1_1_2.zip 1265099 BLAKE2B 15cbb78e8289d7457d8c34112b18293b975046221226630542ffdee1950f8e0cf6120eb69daff57e601f75141b037e5ebc85248f396487e37f4435fbb9e77fe6 SHA512 2373a21f7866173a634adf34c089895ff69022ce24af3a0a9225dc312d659c910df387d26ccd94f3f9f2b79edf5a40a9c101e9040a36f08888cf96228cfcf5b7
DIST jgoodies-binding-1.1.2.zip 1265099 BLAKE2B 15cbb78e8289d7457d8c34112b18293b975046221226630542ffdee1950f8e0cf6120eb69daff57e601f75141b037e5ebc85248f396487e37f4435fbb9e77fe6 SHA512 2373a21f7866173a634adf34c089895ff69022ce24af3a0a9225dc312d659c910df387d26ccd94f3f9f2b79edf5a40a9c101e9040a36f08888cf96228cfcf5b7
diff --git a/dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r1.ebuild b/dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r1.ebuild
deleted file mode 100644
index eb59c57ac80c..000000000000
--- a/dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-ant-2
-
-MY_V=${PV//./_}
-DESCRIPTION="A Java library to bind object properties with UI components"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/binding-${MY_V}.zip"
-
-LICENSE="BSD"
-SLOT="1.0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.4.2
- app-arch/unzip"
-RDEPEND=">=virtual/jre-1.4.2
- examples? ( >=dev-java/jgoodies-looks-1.0.5 )"
-
-S=${WORKDIR}/binding-${PV}
-
-RESTRICT="test"
-
-EANT_FILTER_COMPILER="jikes"
-
-java_prepare() {
- find -name "*.jar" -delete || die
-}
-
-src_install() {
- java-pkg_dojar build/binding.jar
-
- dodoc RELEASE-NOTES.txt || die
- dohtml README.html || die
- use doc && java-pkg_dohtml -r docs/*
- use source && java-pkg_dosrc src/core/com
- use examples && java-pkg_doexamples src/tutorial
-}
diff --git a/dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild b/dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild
deleted file mode 100644
index 4b7c688b3f1c..000000000000
--- a/dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-ant-2
-
-MY_V=${PV//./_}
-DESCRIPTION="A Java library to bind object properties with UI components"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/binding-${MY_V}.zip"
-
-LICENSE="BSD"
-SLOT="1.0"
-KEYWORDS="~amd64 x86"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.4.2
- app-arch/unzip"
-RDEPEND=">=virtual/jre-1.4.2
- examples? ( >=dev-java/jgoodies-looks-1.0.5 )"
-
-S=${WORKDIR}/binding-${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Clean up the directory structure
- rm -rvf *.jar lib
-
- # Copy the Gentoo'ized build.xml
- # cp ${FILESDIR}/build-${PV}.xml ${S}
- java-ant_xml-rewrite -f build.xml -d -e javac -a bootclasspath
- # || die "Failed to fix bootclasspath"
- java-pkg_filter-compiler jikes
-}
-
-src_compile() {
- eant jar # precompile javadocs
-}
-
-RESTRICT="test"
-# Needs X
-#src_test() {
-# eant test -D\
-# -Djunit.jar=$(java-pkg_getjar junit junit.jar)
-#}
-
-src_install() {
- java-pkg_dojar build/binding.jar
-
- dodoc RELEASE-NOTES.txt || die
- dohtml README.html || die
- use doc && java-pkg_dohtml -r docs/*
- use source && java-pkg_dosrc src/core/*
- use examples && java-pkg_doexamples src/tutorial
-}