summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-06-11 11:22:41 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-21 10:11:14 +0200
commit9a5b5df37f2f5018ed0e4effd78c6610b8221ce7 (patch)
treeaed582bf2e1bb1b966d9e215945f0556f13babdd /dev-java
parentmedia-gfx/krita: Fix build with boost-1.73.0 (diff)
downloadgentoo-9a5b5df37f2f5018ed0e4effd78c6610b8221ce7.tar.gz
gentoo-9a5b5df37f2f5018ed0e4effd78c6610b8221ce7.tar.bz2
gentoo-9a5b5df37f2f5018ed0e4effd78c6610b8221ce7.zip
dev-java/byaccj: EAPI 7 bump.
Closes: https://bugs.gentoo.org/724238 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/16191 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/byaccj/byaccj-1.15-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/byaccj/byaccj-1.15-r2.ebuild b/dev-java/byaccj/byaccj-1.15-r2.ebuild
new file mode 100644
index 000000000000..25089c90a947
--- /dev/null
+++ b/dev-java/byaccj/byaccj-1.15-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A java extension of BSD YACC-compatible parser generator"
+HOMEPAGE="http://byaccj.sourceforge.net/"
+MY_P="${PN}${PV}_src"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${PN}${PV}"
+
+src_compile() {
+ cp "${FILESDIR}/Makefile" src/Makefile || die
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" -C src linux
+}
+
+src_install() {
+ newbin src/yacc.linux "${PN}"
+ dodoc docs/ACKNOWLEDGEMEN
+}