summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-18 12:16:37 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-18 12:22:17 -0700
commit0eb1e3806ed6e8dbb9b31c2c0534242259a77c52 (patch)
treed549d510ab720cc3a72175d764c05b4e29e335f2 /dev-lang/rust
parentsys-cluster/ceph: Depend on dev-libs/boost:=[threads(+)] (diff)
downloadgentoo-0eb1e3806ed6e8dbb9b31c2c0534242259a77c52.tar.gz
gentoo-0eb1e3806ed6e8dbb9b31c2c0534242259a77c52.tar.bz2
gentoo-0eb1e3806ed6e8dbb9b31c2c0534242259a77c52.zip
dev-lang/rust: specify stage in toml instead cmdline
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.53.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/rust/rust-1.53.0.ebuild b/dev-lang/rust/rust-1.53.0.ebuild
index 4a8831056258..80e500a51ff8 100644
--- a/dev-lang/rust/rust-1.53.0.ebuild
+++ b/dev-lang/rust/rust-1.53.0.ebuild
@@ -305,6 +305,9 @@ src_configure() {
experimental-targets = ""
link-shared = $(toml_usex system-llvm)
[build]
+ build-stage = 2
+ test-stage = 2
+ doc-stage = 2
build = "${rust_target}"
host = ["${rust_target}"]
target = [${rust_targets}]
@@ -500,8 +503,7 @@ src_compile() {
(
IFS=$'\n'
env $(cat "${S}"/config.env) RUST_BACKTRACE=1\
- "${EPYTHON}" ./x.py build --stage 2 \
- -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
)
}