summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2018-07-16 21:45:20 +0200
committerKeri Harris <keri@gentoo.org>2018-07-16 21:45:43 +0200
commit1e49d9a72ee97e6b4325f81b8fbd541ee4f341e8 (patch)
tree5de47aa17ebbe448c69c62ce4fe1b3301828df70 /dev-lang
parentnet-libs/grpc: version bump to 1.13.1 (diff)
downloadgentoo-1e49d9a72ee97e6b4325f81b8fbd541ee4f341e8.tar.gz
gentoo-1e49d9a72ee97e6b4325f81b8fbd541ee4f341e8.tar.bz2
gentoo-1e49d9a72ee97e6b4325f81b8fbd541ee4f341e8.zip
dev-lang/mercury: handle spaces in mercury PARALLEL args
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mercury/mercury-13.05.2.ebuild10
-rw-r--r--dev-lang/mercury/mercury-14.01.1.ebuild8
-rw-r--r--dev-lang/mercury/mercury-14.01.ebuild10
3 files changed, 14 insertions, 14 deletions
diff --git a/dev-lang/mercury/mercury-13.05.2.ebuild b/dev-lang/mercury/mercury-13.05.2.ebuild
index b0836202a1bf..99339c2a2bc4 100644
--- a/dev-lang/mercury/mercury-13.05.2.ebuild
+++ b/dev-lang/mercury/mercury-13.05.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=2
@@ -69,7 +69,7 @@ src_configure() {
src_compile() {
# Build Mercury using base llds grade
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_LDFLAGS='${LDFLAGS}' \
EXTRA_LD_LIBFLAGS='${LDFLAGS}'" \
@@ -88,7 +88,7 @@ src_compile() {
# Rebuild Mercury compiler using the just built mercury_compiler
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_LDFLAGS='${LDFLAGS}' \
EXTRA_LD_LIBFLAGS='${LDFLAGS}'" \
@@ -99,7 +99,7 @@ src_compile() {
# compile the llds base grade. Since src_test() is run before
# src_install() we compile the default grade now
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_LDFLAGS='${LDFLAGS}' \
EXTRA_LD_LIBFLAGS='${LDFLAGS}'" \
@@ -141,7 +141,7 @@ src_test() {
src_install() {
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_LDFLAGS='${LDFLAGS}' \
EXTRA_LD_LIBFLAGS='${LDFLAGS}'" \
diff --git a/dev-lang/mercury/mercury-14.01.1.ebuild b/dev-lang/mercury/mercury-14.01.1.ebuild
index f192627fc96e..65cb6d098ab2 100644
--- a/dev-lang/mercury/mercury-14.01.1.ebuild
+++ b/dev-lang/mercury/mercury-14.01.1.ebuild
@@ -77,7 +77,7 @@ src_compile() {
# Build Mercury using bootstrap grade
emake \
- PARALLEL="${MAKEOPTS}" \
+ PARALLEL="'${MAKEOPTS}'" \
|| die "emake failed"
# We can now patch .m Mercury compiler files since we
@@ -95,7 +95,7 @@ src_compile() {
# Rebuild Mercury compiler using the just built mercury_compiler
emake \
- PARALLEL="${MAKEOPTS}" \
+ PARALLEL="'${MAKEOPTS}'" \
MERCURY_COMPILER="${S}"/compiler/mercury_compile \
compiler || die "emake compiler failed"
@@ -103,7 +103,7 @@ src_compile() {
# grade. Since src_test() is run before src_install() we compile
# the default grade now
emake \
- PARALLEL="${MAKEOPTS}" \
+ PARALLEL="'${MAKEOPTS}'" \
MERCURY_COMPILER="${S}"/compiler/mercury_compile \
default_grade || die "emake default_grade failed"
}
@@ -147,7 +147,7 @@ src_test() {
src_install() {
emake \
- PARALLEL="${MAKEOPTS}" \
+ PARALLEL="'${MAKEOPTS}'" \
MERCURY_COMPILER="${S}"/compiler/mercury_compile \
DESTDIR="${D}" \
INSTALL_PREFIX="${D}"/usr \
diff --git a/dev-lang/mercury/mercury-14.01.ebuild b/dev-lang/mercury/mercury-14.01.ebuild
index 003906b05deb..3ef81523edac 100644
--- a/dev-lang/mercury/mercury-14.01.ebuild
+++ b/dev-lang/mercury/mercury-14.01.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -72,7 +72,7 @@ src_configure() {
src_compile() {
# Build Mercury using base llds grade
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_CFLAGS='${CFLAGS}' \
EXTRA_LDFLAGS='${LDFLAGS}'" \
@@ -93,7 +93,7 @@ src_compile() {
# Rebuild Mercury compiler using the just built mercury_compiler
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_CFLAGS='${CFLAGS}' \
EXTRA_LDFLAGS='${LDFLAGS}'" \
@@ -104,7 +104,7 @@ src_compile() {
# compile the llds base grade. Since src_test() is run before
# src_install() we compile the default grade now
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_CFLAGS='${CFLAGS}' \
EXTRA_LDFLAGS='${LDFLAGS}'" \
@@ -146,7 +146,7 @@ src_test() {
src_install() {
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_CFLAGS='${CFLAGS}' \
EXTRA_LDFLAGS='${LDFLAGS}'" \