summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-04 23:10:36 +0000
committerSam James <sam@gentoo.org>2023-02-04 23:10:36 +0000
commit9a6e2ac2de6dfe8c28396239cc5d41a1f441a64a (patch)
tree8bb1d89c1d21b7cc2ce89d497df6069be12fed76 /dev-lang
parentmedia-gfx/opentoonz: add 1.6.0 (diff)
downloadgentoo-9a6e2ac2de6dfe8c28396239cc5d41a1f441a64a.tar.gz
gentoo-9a6e2ac2de6dfe8c28396239cc5d41a1f441a64a.tar.bz2
gentoo-9a6e2ac2de6dfe8c28396239cc5d41a1f441a64a.zip
dev-lang/ghc: fix build w/ sphinx 6
Closes: https://bugs.gentoo.org/890563 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/files/ghc-9.0.2-sphinx-6.patch41
-rw-r--r--dev-lang/ghc/ghc-9.0.2-r3.ebuild1
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/ghc/files/ghc-9.0.2-sphinx-6.patch b/dev-lang/ghc/files/ghc-9.0.2-sphinx-6.patch
new file mode 100644
index 000000000000..02364dd8eea5
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-9.0.2-sphinx-6.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/890563
+https://gitlab.haskell.org/ghc/ghc/-/commit/00dc51060881df81258ba3b3bdf447294618a4de
+https://gitlab.haskell.org/ghc/ghc/-/issues/22690
+
+From 00dc51060881df81258ba3b3bdf447294618a4de Mon Sep 17 00:00:00 2001
+From: Matthew Pickering <matthewtpickering@gmail.com>
+Date: Tue, 3 Jan 2023 15:56:37 +0000
+Subject: [PATCH] sphinx: Use modern syntax for extlinks
+
+This fixes the following build error:
+
+```
+ Command line: /opt/homebrew/opt/sphinx-doc/bin/sphinx-build -b man -d /private/tmp/extra-dir-55768274273/.doctrees-man -n -w /private/tmp/extra-dir-55768274273/.log docs/users_guide /private/tmp/extra-dir-55768274273
+ ===> Command failed with error code: 2
+
+ Exception occurred:
+ File "/opt/homebrew/Cellar/sphinx-doc/6.0.0/libexec/lib/python3.11/site-packages/sphinx/ext/extlinks.py", line 101, in role
+ title = caption % part
+ ~~~~~~~~^~~~~~
+ TypeError: not all arguments converted during string formatting
+```
+
+I tested on Sphinx-5.1.1 and Sphinx-6.0.0
+
+Thanks for sterni for providing instructions about how to test using
+sphinx-6.0.0.
+
+Fixes #22690
+--- a/docs/users_guide/ghc_config.py.in
++++ b/docs/users_guide/ghc_config.py.in
+@@ -1,6 +1,6 @@
+ extlinks = {
+- 'ghc-ticket': ('https://gitlab.haskell.org/ghc/ghc/issues/%s', '#'),
+- 'ghc-wiki': ('https://gitlab.haskell.org/ghc/ghc/wikis/%s', '#'),
++ 'ghc-ticket': ('https://gitlab.haskell.org/ghc/ghc/issues/%s', '%s'),
++ 'ghc-wiki': ('https://gitlab.haskell.org/ghc/ghc/wikis/%s', '#%s'),
+ }
+
+ libs_base_uri = '../libraries'
+--
+GitLab
diff --git a/dev-lang/ghc/ghc-9.0.2-r3.ebuild b/dev-lang/ghc/ghc-9.0.2-r3.ebuild
index b7d4466a00c3..1cd220d817eb 100644
--- a/dev-lang/ghc/ghc-9.0.2-r3.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2-r3.ebuild
@@ -544,6 +544,7 @@ src_prepare() {
eapply "${FILESDIR}"/latomic-subword
eapply "${WORKDIR}"/${P}-riscv64-llvm.patch
eapply "${FILESDIR}"/${PN}-9.0.2-fptools.patch # clang-16 workaround
+ eapply "${FILESDIR}"/${PN}-9.0.2-sphinx-6.patch
# mingw32 target
pushd "${S}/libraries/Win32"