summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-01-26 12:45:48 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-01-26 12:58:40 -0600
commitc83dc517fb86ec9df853954bc9295bb843e7a65e (patch)
treec7ec2d405fb79e8d087bd0a184d67340105bde9a /dev-lang
parentx11-libs/libXi: Version bump to 1.7.9. (diff)
downloadgentoo-c83dc517fb86ec9df853954bc9295bb843e7a65e.tar.gz
gentoo-c83dc517fb86ec9df853954bc9295bb843e7a65e.tar.bz2
gentoo-c83dc517fb86ec9df853954bc9295bb843e7a65e.zip
dev-lang/mmix: version bump to 20160804
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mmix/Manifest1
-rw-r--r--dev-lang/mmix/files/mmix-20110420-makefile.patch4
-rw-r--r--dev-lang/mmix/mmix-20160804.ebuild49
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-lang/mmix/Manifest b/dev-lang/mmix/Manifest
index 54e8656685f9..1882639cb66c 100644
--- a/dev-lang/mmix/Manifest
+++ b/dev-lang/mmix/Manifest
@@ -1 +1,2 @@
DIST mmix-20131017.tgz 308016 SHA256 aa64c4b9dc3cf51f07b330791f8ce542b0ae8a1132e098fa95a19b31350050b4 SHA512 e816b1ee9205b9f4a2e25ff183c48736ea66e63721a49f0b574850c5872ae85a6e847d802a01b5aa120ac969638d5d05e9b3135512d9362a4d672564f1228922 WHIRLPOOL e93f29e0a640e219ee2ded0034cbf300e9f6deed2bf9ed04081406cdfaaa952e0b3566525b86e35dfb480288e0ceef1744fefdc533ad0126952603cd698bbb6a
+DIST mmix-20160804.tgz 308410 SHA256 fad8e64fddf2d75cbcd5080616b47e11a2d292a428cdb0c12e579be680ecdee9 SHA512 35c518227a4ee40d0aa3be02eda2ab8b2a27696fa789f5007a978419d07b3deebb7f391895e63e3556aeb38dc1ded3bddf2b860125ebf8f7848375e90dc7af75 WHIRLPOOL 177cc9d3b2426a554628b5487fd7ff9b8098a9292c2f2a14087df526b1af22c4388fa0e812486affd4d07f11ce386a9426ab4729f39b3821a97008e46396a5bd
diff --git a/dev-lang/mmix/files/mmix-20110420-makefile.patch b/dev-lang/mmix/files/mmix-20110420-makefile.patch
index dab062b050f0..14107ed915a9 100644
--- a/dev-lang/mmix/files/mmix-20110420-makefile.patch
+++ b/dev-lang/mmix/files/mmix-20110420-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -27,23 +27,23 @@
if test -r $*.ch; then cweave $*.w $*.ch; else cweave $*.w; fi
diff --git a/dev-lang/mmix/mmix-20160804.ebuild b/dev-lang/mmix/mmix-20160804.ebuild
new file mode 100644
index 000000000000..238f635d2e0b
--- /dev/null
+++ b/dev-lang/mmix/mmix-20160804.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator"
+HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/mmix.html http://mmix.cs.hm.edu"
+SRC_URI="http://mmix.cs.hm.edu/src/${P}.tgz"
+
+RESTRICT="mirror"
+
+DEPEND="virtual/tex-base
+ doc? ( dev-texlive/texlive-genericrecommended )"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="${PN}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20110420-makefile.patch
+ "${FILESDIR}"/${PN}-20131017-format-security.patch
+)
+
+src_compile() {
+ emake all \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)"
+
+ if use doc ; then
+ emake doc
+ fi
+}
+
+src_install () {
+ dobin ${PN} ${PN}al m${PN} mmotype abstime
+ dodoc README ${PN}.1
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins *.ps
+ fi
+}