summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2019-01-18 20:44:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-22 21:50:54 +0100
commitaf43a2c9dc3ec7926956dae3deae1c2c7ec6f506 (patch)
treeb65503427193c46531b7e864dfe7a159915af6dc /dev-libs/hyperscan/hyperscan-5.1.0.ebuild
parentdev-libs/mxml: drop old version (diff)
downloadgentoo-af43a2c9dc3ec7926956dae3deae1c2c7ec6f506.tar.gz
gentoo-af43a2c9dc3ec7926956dae3deae1c2c7ec6f506.tar.bz2
gentoo-af43a2c9dc3ec7926956dae3deae1c2c7ec6f506.zip
dev-libs/hyperscan: Version bump 5.1.0
Closes: https://github.com/gentoo/gentoo/pull/9863 Closes: https://bugs.gentoo.org/674220 Original author: Christian Rößner Signed-off-by: David Heidelberg <david@ixit.cz> Closes: https://github.com/gentoo/gentoo/pull/10864 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/hyperscan/hyperscan-5.1.0.ebuild')
-rw-r--r--dev-libs/hyperscan/hyperscan-5.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/hyperscan/hyperscan-5.1.0.ebuild b/dev-libs/hyperscan/hyperscan-5.1.0.ebuild
new file mode 100644
index 000000000000..ce2fc792b977
--- /dev/null
+++ b/dev-libs/hyperscan/hyperscan-5.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="High-performance regular expression matching library"
+HOMEPAGE="https://01.org/hyperscan"
+
+SRC_URI="https://github.com/01org/hyperscan/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_ssse3 static-libs"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ragel
+ >=dev-libs/boost-1.57:=
+ net-libs/libpcap"
+
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="cpu_flags_x86_ssse3"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex static-libs OFF ON)
+ -DBUILD_STATIC_AND_SHARED=$(usex static-libs ON OFF)
+ )
+ cmake-utils_src_configure
+}