summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Roessner <c@roessner.co>2019-08-21 10:58:49 +0200
committerAlexey Shvetsov <alexxy@gentoo.org>2019-10-06 16:45:37 +0300
commit5c081c3937f44f9616102c8414542b89ae3dd4a0 (patch)
treed0657036d441cc4b987e5918e952ec2e35c8455d /dev-libs/hyperscan/hyperscan-5.1.1.ebuild
parentmedia-libs/lensfun: Upstream now on github (diff)
downloadgentoo-5c081c3937f44f9616102c8414542b89ae3dd4a0.tar.gz
gentoo-5c081c3937f44f9616102c8414542b89ae3dd4a0.tar.bz2
gentoo-5c081c3937f44f9616102c8414542b89ae3dd4a0.zip
dev-libs/hyperscan: Version bump to 5.1.1 and 5.2.0
Signed-off-by: Christian Roessner <c@roessner.co> Closes: https://github.com/gentoo/gentoo/pull/12757 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-libs/hyperscan/hyperscan-5.1.1.ebuild')
-rw-r--r--dev-libs/hyperscan/hyperscan-5.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/hyperscan/hyperscan-5.1.1.ebuild b/dev-libs/hyperscan/hyperscan-5.1.1.ebuild
new file mode 100644
index 000000000000..7d40d8fff80f
--- /dev/null
+++ b/dev-libs/hyperscan/hyperscan-5.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="High-performance regular expression matching library"
+SRC_URI="https://github.com/01org/hyperscan/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://01.org/hyperscan"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_ssse3 static-libs"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-util/ragel
+ dev-libs/boost
+ net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="cpu_flags_x86_ssse3"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex static-libs OFF ON)
+ -DBUILD_STATIC_AND_SHARED=$(usex static-libs ON OFF)
+ )
+ cmake-utils_src_configure
+}