summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-03-11 19:10:49 -0800
committerMatt Turner <mattst88@gentoo.org>2017-03-16 13:36:41 -0700
commit1242028336dd4772161f7e0d504b1ef0d428099a (patch)
tree496f5fb1f789c225c67d8e04ff1f5b665386e55e /dev-libs/wayland/wayland-1.7.0.ebuild
parentdev-libs/libwacom: Drop old versions (diff)
downloadgentoo-1242028336dd4772161f7e0d504b1ef0d428099a.tar.gz
gentoo-1242028336dd4772161f7e0d504b1ef0d428099a.tar.bz2
gentoo-1242028336dd4772161f7e0d504b1ef0d428099a.zip
dev-libs/wayland: Drop old versions
Diffstat (limited to 'dev-libs/wayland/wayland-1.7.0.ebuild')
-rw-r--r--dev-libs/wayland/wayland-1.7.0.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-libs/wayland/wayland-1.7.0.ebuild b/dev-libs/wayland/wayland-1.7.0.ebuild
deleted file mode 100644
index d317981c361c..000000000000
--- a/dev-libs/wayland/wayland-1.7.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
- GIT_ECLASS="git-r3"
- EXPERIMENTAL="true"
- AUTOTOOLS_AUTORECONF=1
-fi
-
-inherit autotools-multilib toolchain-funcs $GIT_ECLASS
-
-DESCRIPTION="Wayland protocol libraries"
-HOMEPAGE="https://wayland.freedesktop.org/"
-
-if [[ $PV = 9999* ]]; then
- SRC_URI="${SRC_PATCHES}"
-else
- SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="doc static-libs"
-
-RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
- >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? (
- >=app-doc/doxygen-1.6[dot]
- app-text/xmlto
- >=media-gfx/graphviz-2.26.0
- sys-apps/grep[pcre]
- )
- virtual/pkgconfig"
-
-src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_enable doc documentation)
- )
- if tc-is-cross-compiler ; then
- myeconfargs+=( --disable-scanner )
- fi
- if ! multilib_is_native_abi; then
- myeconfargs+=( --disable-documentation )
- fi
-
- autotools-multilib_src_configure
-}
-
-src_test() {
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- autotools-multilib_src_test
-}