summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/PEAR-Console_Getopt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/PEAR-Console_Getopt')
-rw-r--r--dev-php/PEAR-Console_Getopt/Manifest2
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.3.1.ebuild28
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.0.ebuild28
-rw-r--r--dev-php/PEAR-Console_Getopt/metadata.xml5
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getopt/Manifest b/dev-php/PEAR-Console_Getopt/Manifest
new file mode 100644
index 000000000000..f4829627db48
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/Manifest
@@ -0,0 +1,2 @@
+DIST Console_Getopt-1.3.1.tgz 4471 SHA256 9381ad3f8e48574c38917b55caae2cd20cf152af8e65a31d09931fad829161c4 SHA512 701c2861bcf07c121e573441dec783b4e832b10d439bf807076427cbfa832ebcd80a20c324296e962d7f493e51231f5c54b46fd19e83a431db17f21b7d984876 WHIRLPOOL a2028ae0ea556ce9821249527c1abccc8757425b67cbc7a842487fc86b09cbd075405a1f7477fae802aa0014a7aa2ddbfbb9ad534f907a81a562e71d5e099903
+DIST Console_Getopt-1.4.0.tgz 4534 SHA256 634a8647ce2b343253c57d77f42361464eebe28a3b4c0a321c6675495da88fab SHA512 1da827cb3740de139ba0721c82dbe374b05fbf7e08e0eecfaa4b53f8d0024be1bbaa737a3c9b7a21ac2779dc4036480d3d6d85f7bd83cb07db0cc234ea193a1c WHIRLPOOL f7a36d4898f8c7cc7aff655ebb9a6037eb9cdde03f981ced353fa6e59ddfa6b568f8e56eab14b55ab988408321a4b359353d226f364a42d93ae99c611d8996fe
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.3.1.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.3.1.ebuild
new file mode 100644
index 000000000000..34c764a7ed68
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line option parser"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Console_Getopt"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php/
+ doins -r Console
+}
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.0.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.0.ebuild
new file mode 100644
index 000000000000..d2487e44f01f
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line option parser"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND=">=dev-lang/php-5.4:*
+ >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Console_Getopt"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php/
+ doins -r Console
+}
diff --git a/dev-php/PEAR-Console_Getopt/metadata.xml b/dev-php/PEAR-Console_Getopt/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>